8

Hello members I'm running Ubuntu 12.04.1 LTS 32 bit my only problem is that I'm from Bulgaria and when a download movie with Bulgarian subs VLC player is not showing them properly how can i fix that ?

screenshot

6

It seems that your problem is related to the encoding of the subtitles. Check the instructions at the VLC's page on subtitles to adjust your preferences to whichever enconding was used to create the subtitle file.

Fonts in your Ubuntu installation should show cyrillic letters with no problem (anyway, that doesn't seem to be your problem).

If you need to change the encoding of your subtitle file, follow instructions given in this answer.

  • @Bodyshaker if the answer was helpful consider accepting it by clicking on the checkmark, you can "upvote" it too. – guntbert Feb 20 '14 at 21:20
4

I came here for help, but I found the answer myself. In the VLC player menu, go to Tools, Preferences, Subtitles/OSD, then under Default Encoding choose Cyrillic (Windows-1251). You may need to restart the program in order for the change to take effect.

Успех! Ganbatte!

0

If your fonts doesn't display correctly with text editor then you can use reopen with encoding using sublime for example, then select the same encoding in VLC. VLC encoding wont be enough if you can't read the Cyrillic subtitles with your text editor. Example: reopen file with Cyrillic (Windows-1251) then set the same for default in VLC. external link for more info

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.