32

When I use the print screen key - PrtSc - I get the option of where to save. That works fine.

However when I shift-ctrl-PrtSc I hear the picture being 'taken' but I don't get a chance to specify the location.

I have checked the following locations and they do NOT have the screenshot:

My Desktop
My Documents
My home directory
34

As I know holding Ctrl copies the screenshot to the clipboard and you need to paste it in an application to save it.

You can check the shortcut keys in Keyboard Settings.

Screenshot shortcuts

| improve this answer | |
9

I played around some more and found that using Alt-Fn-PrtScn will copy the window only and then give me the option of where to save.

2014 - Update

PrtScn - Capture the entire screen (all windows) and ask where to save
Alt PrtScn - Capture the currently focused window and ask where to save
Shift PrtScn - Select specific area for capture and ask where to save

| improve this answer | |
  • I am used to using alt+print method. But, do you know how to change it's default save folder? I tried to configure it in dconf-editor, I set the auto-save-directory of gnome-screenshot to specified location. But, it doesn't work. It still saves the captured picture in My Pictures folder. – Oki Erie Rinaldi Aug 13 '15 at 4:16
  • It isn't like you said (".. and then give me the option of where to save."). It's automatically save the picture to My Pictures folder. And oh, I was using gnome desktop instead of unity. – Oki Erie Rinaldi Aug 13 '15 at 4:20
  • A bit late, you can use this command gnome-screenshot --interactive in terminal to open gnome-screenshot graphic interface. I suggest to make an alias in your ~/.bashrc (e.g. alias screenshot="gnome-screenshot --interactive") – duykhoa Sep 10 '18 at 16:57
3

Shift+PrtScn is a better way, as you will be prompted for where to save the screenshot (and by what filename).

| improve this answer | |
  • 1
    Dude! Thank you for teaching me how to use the kbd tag for those icons. Now let me try it in a comment: <kbd>Shift</kbd>+<kbd>PrtScn</kbd> - Nope. Doesn't work here. But that is great to know. – SDsolar Aug 17 '17 at 23:27
  • Eliah Kagan Thanks for your edit, it helps me for better understanding (for English and Stackoverflow :D) – Khaschuluu Munkhbayar Oct 24 '17 at 1:35
  • 1
    Ubuntu 18.04, no prompt. Simply saved. – NelsonGon Jul 7 '19 at 10:39
2

Very simple answer to your direct question(s):

Ctrl-PrtSc will copy the whole screen to the clipboard. It is not saved on disk.

To get a partial, you add Shift, whether you use Ctrl (clipboard) or not (save and/or clipboard).


Of course, you probably know that just pressing PrtSc will capture the whole screen and give you the options to save to clipboard and/or save it to disk, with a default directory of ~/Pictures

| improve this answer | |
1

try using Shutter instead, It's awesome:

sudo add-apt-repository ppa:shutter/ppa    
sudo apt-get update && sudo apt-get install shutter

However I think you can also try this not sure if it will fix that exactly:

gsettings set org.gnome.gnome-screenshot auto-save-directory to 
file:///home/yourusername/wherever/you/want

you can also use get to see where it is suppose to be saving them:

gsettings get org.gnome.gnome-screenshot 

Source: Why doesn't the PrintScreen dialog show up in Gnome?

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.