After doing a pretty exhaustive search and trying every possible solution I've found on this lovely forum (no joke), my screen brightness is stuck on max. I'm running Ubuntu 12.04. Seems to be a common problem, but it's a little frustrating that nothing seems to work.

Going into system settings, it appears to be set on minimum (yet it hurts my eyes even in a brightly-lit room), and sliding it back and forth doesn't change anything.

Alternatively, is there any software that will dim the brightness to a more tolerable level, in case I continue to run into brick walls?


  • 1
    What video card ? – Panther Feb 13 '13 at 16:40
  • Possibly a duplicate of askubuntu.com/questions/224791/…. – guntbert Feb 13 '13 at 20:41
  • @bodhi- You're onto something there.. there appears to be a problem with my graphics card. It's identified as "unknown" and I'm seeing a warning that a driver I apparently need is not supported. Any suggestions? Besides downgrading, which I'm already considering. – killerrobot Feb 16 '13 at 0:58
  • @guntbert- I have read many other threads about this problem, it doesn't seem to be too rare, although their systems are slightly different. Unfortunately, none of those solutions have worked for me. – killerrobot Feb 16 '13 at 1:01
  • I am having the same issue though I do not understand the lingo. Can you explain for everyday folks Thanks. – user166497 Jun 12 '13 at 1:42

On my aspire it's as simple as adding the first line I mention here.

Try editing /etc/default/grub with the following values:

Open a terminal and type sudo gedit /etc/default/grub.

First try changing the line that reads : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Then save, close gedit and type sudo update-grub and reboot the computer.

If after this it still does not work, you can also try changing the same line to read

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

and then again running sudo update-grub and rebooting the computer.

  • Thanks for taking the time, but none of this seems to work. After the first change, the hotkeys did literally nothing (before, the brightness slider would pop up in the top right corner, but the brightness wouldn't actually adjust). It also seemed to take away the brightness slider under system settings entirely. The second change brought those back, but they still don't have any effect. – killerrobot Feb 16 '13 at 0:53

On the keyboard, there should be a brightness key (Usually a FN key) to set it.

Hope this helps!

  • 1
    He must have tried it and didn't work out. – smartboyhw Feb 13 '13 at 17:25
  • Yup, that would be the first thing I tried... – killerrobot Feb 16 '13 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.