I have installed DesktopCouch on my Lubuntu 12.10 using apt-get

sudo apt-get install desktopcouch

Installation was ok, but when I try to start it with command couchdb, I get the following error:

{"init terminating in do_boot",{{badmatch,{error,{bad_return,{{couch_app,start,

Crash dump was written to: erl_crash.dump
init terminating in do_boot ()

Line-breaks added to the JSON for better readability

I have checked file /etc/couchdb/default.ini and I have created folder for data mentioned there (it was /var/lib/couchdb/1.2.0/) and assigned the 777 access rights to it. But it doesn't help.

I also tried sudo couchdb, but the result is the same.

File, mentioned in the error (erl_crash.dump) has 16k lines, makes no sense to me

I checked and another CouchDB is not running:

$ couchdb -s
Apache CouchDB is not running.

Running out of ideas... Do you know what the problem might be?


Don't install or use desktopcouch. It is no longer maintained or supported. See the EOL announcement for desktopcouch. Also, couchdb will soon be completely disabled on the Ubuntu One servers, as announced recently. It's not stated in that announcement, but notes sync was the last remaining service backed by couchdb on the server. Once it's down, there will be no more couch access on Ubuntu One (syncing with which was the sole reason for desktopcouch). The desktopcouch package has been removed from the archive completely in 13.04.

  • I'm not talking about Ubuntu One, but about Lubuntu, installed on my laptop. I simply need to get any kind of CouchDB instance running on my laptop. Is there any chance? – Tom Burger Feb 14 '13 at 16:43
  • CouchDB is a system service. sudo service couchdb start should start it, but you may be missing a required package for that if you install desktopcouch as a way of getting couchdb. – dobey Feb 14 '13 at 20:26
  • ok, I removed desktopcouch, I installed regular couchdb. Now the command couchdb gives still the same error, but sudo service couchdb start works and it really starts couchdb. Thanks... – Tom Burger Feb 14 '13 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.