ASUS Zenbook Prime, Ubuntu 12.10 using double boot with Windows 7.

While working in Ubuntu, suddenly file icons didn't display properly anymore (all icons where the same white page) and desktop turned to blue, though everything else still worked. Best I can reconstruct this happened when I downloaded some software updates (gloobus-preview, weather icon, and one other) - and the install didn't work with Ubuntu complaining about a segmentation fault.

I restarted computer and now after logging in to Ubuntu - which looks mostly normal, though the icons in the notification area don't show properly - I get a blue screen, no unity, desktop icons, or notification area. I can get to a terminal using ctrl+alt+t, but I can't type into it.

  • I've restarted multiple times with same result.
  • Everything works fine both using the Windows 7 boot and booting Ubuntu from a USB stick.
  • I can get to command-line login and then to regular command line
  • Using Advanced Ubuntu options in the GRUB loader I can get to recovery and regular boot for current and prior kernels. None of the older kernels work & I couldn't make much sense of the recovery options, though would be happy to add any debug that's useful.

  • I did run through the package repair which complained of a broken gloobus-preview. In removed gloobus-preview using sudo apt-get remove in the command line - didn't check anything after reboot.

  • I read through this: My Ubuntu 12.10 does not startup to GUI but most answers don't seem to apply as the Zenbook has a generic Intel graphics card that has never been a problem before.

Would be grateful for any suggestions!

update: So I've been able to type into the terminal and tried starting some programs - this is kind of randomly for apturl, but it looks very similar for unity and compiz (with dozens of the unrecognized image file format issues preceding it). So this looks like a GTK problem? Any thoughts on how to fix this?

(apturl-gtk:417): Gtk-WARNING **: Theme parsing error: unity.css:32:51: Unrecognized image file format

(apturl-gtk:417): Gtk-WARNING **: Unknown property: GtkDialog.has-separator
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/AptUrl/AptUrl.py", line 142, in parseArgs
    apturl_list = Parser.parse(args[0])
IndexError: list index out of range

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/apturl-gtk", line 47, in <module>
  File "/usr/lib/python3/dist-packages/AptUrl/AptUrl.py", line 169, in main
    apturl_list = self.parseArgs()
  File "/usr/lib/python3/dist-packages/AptUrl/AptUrl.py", line 144, in parseArgs
    self.ui.error(_("Need a url to continue, exiting"))
  File "/usr/lib/python3/dist-packages/AptUrl/gtk/GtkUI.py", line 59, in error
    d = self._get_dialog(Gtk.MessageType.ERROR, summary, msg)
  File "/usr/lib/python3/dist-packages/AptUrl/gtk/GtkUI.py", line 52, in _get_dialog
    d.set_icon(Gtk.IconTheme.get_default().load_icon('deb', 16, False))
  File "/usr/lib/python3/dist-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: Icon 'deb' not present in theme
  • What does "all icons where the same white page" mean? – Eliah Kagan Feb 12 '13 at 21:23
  • the file icons that are usually different for each file type - the Libre Office logo for .odt, a folder with a zipper for .zip etc. - were all the same: a white rectangle (that looks like an empty page). – adam.smith Feb 12 '13 at 21:29

This is only a partial answer, i.e. I don't have a solution, but I know what went wrong. I'm pretty sure I've isolate the culprit, which was, well, mainly me: I had added Ricotz's Ubuntu testing ppa: http://ppa.launchpad.net/ricotz/testing/ubuntu - I had added it only to install Ubuntu Tweak, but should have read the details more closely. In any case it updated various gtk and gdk libraries in a way that I wasn't able to fix things anymore and ended up re-installing Ubuntu.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.