This might be a duplicate of other password related questions but it's somehow eccentric.

I have three accounts in my Ubuntu 12.10 system (one standard and two administrators). One of the administrator accounts is my main development account and suddenly before yesterday, it started to act weird (since the latest updates - Kernel and others:

  • At the greeter stage, when I enter my password, it instantly returns 'Incorrect password'. It does not even check. (N.B: The password is absolutely correct)
  • At TTY, impossible to login, once I enter my login name and then the password, it instantly re-prompts me to enter the login name...It feels like tha path to authenticate this account has been accidently locked or access-sealed.

I logged in with my second admin account and changed the password for the troublesome account, but no luck, reverted the password back to its original value and set the account to auto-login. rebooted and then, indeed the account logged in. Yet, the abonormality remains:

  • I cannot perform root privilege actions (sudo & gksudo). Once I enter my password, nothing happens. The only time when the password is accepted is when the screen is locked and that I am prompted to enter the password to unlock it.

I checked the ownership of my home folder and it's okay. I have no clue why this is happening. Some help is very appreciated.

*I provide some logs (dmesg , /var/log/auth.log ...etc) here: * https://unix.stackexchange.com/questions/64545/suddenly-i-cant-login-with-correct-password-greeter-tty


Problem solved.

Here are the actions I carried out before the problem got solved:

In order to revert back to supported gnome packages like nautilus, etc, run

sudo ppa-purge ppa:gnome3-team/gnome3

Create directory /var/lib/samba

sudo mkdir -p /var/lib/samba
sudo smbpasswd -a myusername

Then run

sudo pam-auth-update

All the authentication modules were already selected, so I just clicked okay.

Troubleshooting here: http://ubuntuforums.org/showthread.php?t=2115288

  • If I may, how did you carry out these commands without getting inside the Terminal? I have tried CTRL ALT F2 but it doesn't like the ppa-purge command. I only ask because I don't want to make a duplicate question. – BJsgoodlife Jun 30 '16 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.