I am using Evince document viewer as default in ubuntu 12.04.

How do I get a hyperlink to open when clicking on it?

2 Answers 2


You encountered a bug but there is a quick fix, I just did it and it worked, thanks to @maggotbrain by the way. He pointed me to this comment, and the suggested solution worked. So I was able to fix this issue with google chrome by doing the following:

  1. Open a terminal, type gksudo nautilus and hit enter,type your password and hit enter again, so now you are running nautilus with root privileges.
  2. On nautilus go to /etc/apparmor.d/abstractions/
  3. Open the ubuntu-helpers file and locate this lines inside:

    # Allow exec of libexec applications in /usr/lib*

    /usr/lib*/{,**/}* Pixr,

  4. You will insert this block of text after those lines:

    # From https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/964510/comments/12
    # While the chromium and chrome sandboxes are setuid root, they only link
    # in limited libraries so glibc's secure execution should be enough to not
    # require the santized_helper (ie, LD_PRELOAD will only use standard system
    # paths (man ld.so)).
    /usr/lib/chromium-browser/chromium-browser-sandbox PUxr,
    /opt/google/chrome/chrome-sandbox PUxr,
    /opt/google/chrome/google-chrome Pixr,
    /opt/google/chrome/chrome Pixr,
    /opt/google/chrome/lib*.so{,.*} m,

    but before this line:

    # Full access
  5. Save the file, close nautilus.

  6. Finally, type sudo apparmor_parser -T -W -r /etc/apparmor.d/usr.bin.evince on the terminal and hit enter, wait a few seconds until there is a line break and the cursor is awaiting for new input, this means the command went through with no problems :) hope it was helpful.

  • 1
    If by any chance it didn't work just open the file again, erase the same lines, save it and run sudo apparmor_parser -T -W -r /etc/apparmor.d/usr.bin.evince again. Jul 9, 2013 at 8:53
  • I went through all of this, as well as other stuff here, but haven't been successful yet, I still get the same error: askubuntu.com/questions/997511/….
    – James Ray
    Jan 19, 2018 at 3:53
  • I am having the same issue. Is this still a bug in 20.04? I feel like this was probably fixed the last ten years and I am dealing with something else.
    – Kvothe
    Mar 21 at 11:34
  • Open the /usr/share/applications/mimeinfo.cache file.
  • Search for the lines containing x-scheme-handler/http= and x-scheme-handler/https=.
  • You should have either firefox.desktop or any other browser name followed by .desktop after the text in those lines.
  • For example the line may read:
  • What does this have to do with the OP's question?
    – Cerin
    Dec 12, 2016 at 18:25
  • I tried reordering chrome, firefox and brave to brave, firefox and chrome (I prefer this order), but that didn't help.
    – James Ray
    Jan 19, 2018 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.