we recently bought a new windows 8 laptop, and we are trying to install Ubuntu to it in a dual boot configuration. I downloaded the 64 bit 12.10 iso and put it in a USB stick, both with the utility recommended from the Ubuntu installation guide and with Unetbootin. However, when I reboot the laptop and select from BIOS the USB as first option, it just flashes the Toshiba logo for 2 seconds and then reboots again and does this ad infinitum (I disabled SecureBoot) until I remove the usb stick and then it boots normally into windows. If I however turn on the option CSM/legacy boot in the BIOS I CAN boot into the usb installer, so I don't think it is an issue with the usb stick nor the iso image.

The question is, how do I get it to boot in UEFI mode? Or should I just keep going in legacy mode and hope the installer recognizes the UEFI boot?

  • I have not tried this, which is why this is a comment not an answer, but there is a long discussion here. Try it if it works you can summarize the process as an answer and earn some reputation too. – Warren Hill Feb 12 '13 at 13:10
  • You could also see if a firmware update is available for your computer. Such updates sometimes fix problems like the one you've described, although that's far from guaranteed to work. – Rod Smith Feb 13 '13 at 17:25

In the end I ended up installing it in CSM/Compatibility mode. It didn't boot. But then using the Ubuntu version with BootRepair as a Live USB disk I ran BootRepair and it installed the EFI files and changed the booting mode and it worked. I still have no idea why it didn't work from the beginning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.