I tried to install Ubuntu 12.10 with the Wubi installer while running Windows, because my PC does not accept my BootCD as a bootable medium.

But Wubi showed me this error:

(X) Ein Fehler ist aufgetreten:
Could not retrieve the required disk image files
Weiter Informationen finden Sie in der Protokolldatei:

What can I do, because I want to get rid of my Windows 7 and use the way better Ubuntu 12.10?

Thanks for your huge answer, now my next problem after trying to install wubi with the .iso is, that the same error shows up again and i am not shure which part of the errorreport you need.

Can you tell me? Because i'm not that good at linux.

  • How did you download the ISO? What is its name? Is it in a folder with wubi.exe and nothing else? How are you running wubi.exe? What happens when (with it and the ISO image in the same folder) you right-click on it and click Run as Administrator? What is the complete and exact text of the .log file referred to in the error message? (You can open up this file in Windows and look at it. Paste it into your question and use the <$> tool to make the text appear correctly, or use paste.ubuntu.com and provide the URL here.) Did you MD5SUM the ISO? (Please edit again with this info.) – Eliah Kagan Feb 12 '13 at 20:43
  • My ISO was another version, but had the same name, I guess. Because after redownloading it into the wubi folder and replacing the old one, everything worked just perfect. I am writing this on Ubuntu, and i LOVE it. – Daniel Feb 12 '13 at 21:02
  • Excellent, I'm glad it worked. It was probably a corrupted ISO (a bad download) rather than one for a different version (as then the name would've been different unless you changed it when you downloaded it, or later). As I said in my answer, please remember that if you want to remove the Windows system and keep using Ubuntu, you'll need a normal (not Wubi) installation of Ubuntu. – Eliah Kagan Sep 14 '17 at 19:16

I cannot tell you exactly what went wrong, because you didn't include anything from the log file the error message told you has more information.

However, the general problem is that the Wubi installer is unable to download an Ubuntu ISO image.

  • One common cause of this problem is that the Wubi installer is unable to use bittorrent. This is how it downloads ISO images. No special software is required on your computer to facilitate this (wubi.exe contains everything necessary). But, this does not work well on some Internet connections. Yours could be one.
  • If you want more detailed information about the cause of the problem, please edit your question to include the contents of that log file (c:\users\username\appdata\local\temp\wubi-12.10-rev273.log).

It sounds like you already tried burning an Ubuntu ISO to a DVD, so you probably already have an ISO image. If you do, and if it is an ISO image for Ubuntu 12.10, just put it and wubi.exe (the Wubi installer) in a folder that contains no other files, and run wubi.exe again.

If you don't have an appropriate ISO image, you can download one manually on the download page, and put it in an otherwise empty folder with wubi.exe.

If you're already running Wubi from the DVD you burned (or from a USB flash drive you created, or by mounting the ISO image), then this means the installation medium is corrupted. That is, either the ISO image contains wrong data, or the DVD/USB contains wrong data (which could happen from wrong data in the ISO, or due to other problems, most commonly due to something going wrong when it is burned/written).

So if that's the case, MD5 test the ISO image. If it's bad, download the ISO again (and test it again too). If it's good, make sure you're burning the DVD or writing the USB flash drive correctly. In particular, remember that the desktop ISO for Ubuntu 12.10 (but not earlier versions) requires a DVD, it is too big to fit on a CD.

Sometimes a DVD will come out better if you burn it at a slower speed.

Wubi might not meet your needs, though.

You said:

What can I do, because I want to get rid of my Windows 7 and use the way better Ubuntu 12.10?

If you install with Wubi, Ubuntu will be installed inside a rewritable disk image file stored inside your Windows system. So, while Windows will not be running while you use Ubuntu, you will not be able to remove Windows and keep Ubuntu. (Actually, you could, if you converted your Wubi installation to a regular installation. But you would have to be able to boot from external media to do this, so if you can do that, then you can just install a regular Ubuntu system in the first place.)

So you probably shouldn't use Wubi. How you should install Ubuntu depends on what went wrong in your first attempt (before you tried Wubi):

If you tried to burn it to a CD, that won't work starting with 12.10 (the version you're trying to install). Burn it to a DVD instead.

If your computer won't boot DVDs, or you don't have a DVD, or you'd prefer not to use a DVD, then you can write the ISO image to a USB stick instead.

As stated above, your ISO image, DVD, or USB flash drive could be corrupted. So test the ISO image, and make sure you're writing the DVD or USB correctly (see the two links just above this paragraph). Corruption can interfere with regular installations as well as Wubi installations, and can even prevent your DVD from booting entirely. As stated above, if you're trying to install from a DVD, burning the DVD slowly can reduce the likelihood of corruption.

If your DVD/USB boots but doesn't get very far, then you can usually test the DVD/USB itself. When you see a purple screen with person and keyboard icons at the bottom (this is very early in the boot process after you boot from the DVD/USB), press a key to bring up the text-based boot menu. Then select Check disc for defects. For more information on this, see the community documentation and this video.

If none of that works, you'll have to provide more information about exactly what you've done and what happened, including exactly what happened when you tried to boot, and any error messages that appeared at any point.


When I looked at the log file I saw he's trying to download files from a 404. Here's what fixed it for me - I just had an old installation file.

When googling "Download wubi" go to the newest link e.g. I used: https://softfamous.com/postdownload-file/wubi/3746/706/

Install from the executable you download.

protected by Byte Commander Dec 21 '16 at 12:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.