I'm using Ubuntu 12.04 (64-Bit Kernel Linux 3.2.0-38-generic GNOME 3.4.2) on a Intel i5-2400.

Unity has always run in 3D mode. After Ubuntu installed updates, it started freezing after login. So I ran the recovery mode to fix broken packages.

Ubuntu is running again but now Unity is in 2D mode.

I have tried to reinstall xserver and graphic drivers but nothing is fixing my problem. It's already saying that I'm using the lastest xserver-xorg-video-intel version.

/usr/lib/nux/unity_support_test -p
OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
OpenGL version string:  2.1 Mesa 9.0

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

Does anyone have an idea on how to get 3D mode working again?

1 Answer 1


Ok the problem is solved now.

I had the freeze every day after 1st login and had to run the repair packages tools. But it looks like an update yesterday has fixed the bug which came with an update...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.