Good afternoon,

I'm trying to set up wireless on a new install of Ubuntu Desktop 12.10.

I am able to connect to "open" wireless networks (I am connected to my house "guest" wifi network right now) - therefore the problem is not with the wireless card or firmware (I've done b43-fwcutter & firmware installs).

The issue is just when trying to connect to my WPA2 secure "normal" wifi network ("bkhouse"). It just won't seem to go... It appears that I can connect to the SSID, but it won't complete the connection.

Help would be appreciated!!

brandon@linux-desktop:/etc/wpa_supplicant$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:25:64:db:89:16  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1517 errors:0 dropped:0 overruns:0 frame:0
          TX packets:944 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1802381 (1.8 MB)  TX bytes:95348 (95.3 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8926 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8926 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:737296 (737.2 KB)  TX bytes:737296 (737.2 KB)

wlan0     Link encap:Ethernet  HWaddr 00:0f:66:6f:19:2c  
          inet6 addr: fd63:da35:957a:0:20f:66ff:fe6f:192c/64 Scope:Global
          inet6 addr: fe80::20f:66ff:fe6f:192c/64 Scope:Link
          inet6 addr: fd63:da35:957a:0:cc16:dc3c:c7f5:e400/64 Scope:Global
          RX packets:4397 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3964 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2716198 (2.7 MB)  TX bytes:827754 (827.7 KB)

brandon@linux-desktop:/etc/wpa_supplicant$ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"bkhouse"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 58:6D:8F:28:26:69   
          Bit Rate=48 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=63/70  Signal level=-47 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:40   Missed beacon:0

P.S. I've tried all kinds of different configurations with wpa_supplicant but haven't been able to sort anything out!


You might need to edit /etc/network/interfaces to add the passkey, if you're not being given a chance to enter it manually when you connect. See solution here:


which references: http://ubuntuforums.org/showthread.php?t=202834

Or alternatively: https://superuser.com/questions/42460/can-you-explain-how-to-understand-what-the-iwconfig-command-displays-in-ubuntu

| improve this answer | |
  • Thanks for the reply! I tried this, but I also realized I had previously reserved an IP for my desktop's MAC address on my router.... One of the two was probably the issue. – Brandon Feb 11 '13 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.