I just installed Ubuntu 12.10 on an ASUS X401U, and after installation there is no list of wireless connections. I didn't have that problem with an installation on HP. What I can do to enable Wifi?

07:00.0 Network controller [0280]: Ralink corp. Device [1814:3290]
  • 2
    This is the bug for support for this card, it might contain information that can help: bugs.launchpad.net/ubuntu/+source/linux/+bug/1049466 Commented Apr 8, 2013 at 14:50
  • @JorgeCastro Nice bug report. I read all bug reports there. Will only add the ones that have less chance of creating a problem for the user. For example forcing the user to either change Ubuntu version or apply a kernel not meant for that particular version are bad in my opinion (I could kill a workable computer with that). I simply focused on using the official site for the drive and corrected issues related to that driver. At the end added some tips about the procedure. Commented Apr 8, 2013 at 15:57

2 Answers 2


There are several guides that speak of the same way. Guides like this source, this source or the bug report mention some procedures to get this Wireless card working on several types of laptops.

Some cases mention downgrading to 12.04 and then installing a specific 3.6 kernel version for it, others mention upgrading to 13.04 and installing the 3.9 kernel version. And even another case where it mentions the user to download the drivers from the official site and do a step by step guide on how to install it.

I will mention several ways of doing it, all of which involve downloading the driver, compiling it and making sure it works. It has been noted that in the 3.9 kernel version, the wireless card is working correctly, so in 13.04 with backports or 13.10 this issue should be resolved.

So here are several ways you can get your Ralink RT3290 wireless card working in 12.04 and above (Not all methods will work, so try to look for the one that works best for your computer):

Since your vendor id is 1814:3290 it means you have a Ralink RT3290 wireless card. For that case we (After connecting the wired cable):

  1. Connect a wired cable connection to the computer to have Internet connection for the moment while you do the steps below.

  2. Open a terminal and execute the following line to install everything needed to compile your very own wireless drivers:

    sudo apt-get update && sudo apt-get install build-essential linux-headers-generic

Now, depending on how you wish to proceed, follow one of the guides below:


If the above does not work for you on Kernels 4.X, the solution I was able to test following this source was

PLease Download the Updated Driver (Big Thanks to Jim Colaco) From Here or Here. This was tested on Ubuntu 16.04 and 16.10.

sudo tar -xvf rt3290sta- -C /usr/src
sudo dkms install -m rt3290sta -v --force
sudo reboot

Now on some cases, you will need to enable the interface for the wireless driver (Because it will not bring the interface up automatically) and then restart the network service. Something like this:

sudo ifconfig WIRELESSCARD up
sudo service network-manager restart

So an example would be:

sudo ifconfig eno1 up
sudo service network-manager restart

I recommend putting this 2 lines inside /etc/rc.local above the "exit 0" line so it brings the interface up automatically.


  1. Go to Mediatek and download the Ralink RT3290 Driver for Linux MediaTek did a fine job on moving the link to download and not having a redirect for it. Here is the new Link for all Downloadable Firmware but guess what, they removed RT3290 from it. Go Mediatek ;)

    Thanks to others that also had the problem and shared their sources, here is a list of all available Download links for you to use while Mediatek decides to help Linux and open up:

  2. Rename the file to 2012_0508_RT3290_Linux_STA_v2.6.0.0.tar.bz2 because Mediatek did a great job on making sure the file works correctly.

  3. Extract the file and it should create a folder named DPO_RT3290_LinuxSTA_V2600_20120508

  4. Go to DPO_RT3290_LinuxSTA_V2600_20120508/os/linux/ and edit the file config.mk

  5. On line 31 you should find the variable HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n. Change it to 


      and save the file.

  6. Go to your main extracted folder (It should be the DPO_RT3290_LinuxSTA_V2600_20120508 folder) and type:

    sudo make install
  7. If everything compiled correctly do the following:

    modprobe rt3290sta
  8. If step 7 runs without any problems, we add the module to the list of modules to loaded on every boot:

    sudo -H gedit /etc/modules

     and add a line at the end of the file that says rt3290sta. Save and exit.


(Not recommended, as you're downloading an untrusted tarball off of a Dropbox account.

  1. Download the source driver:

    wget http://dl.dropbox.com/u/11876059/DPO_RT3290_LinuxSTA_V2600_20120508.tar.gz

    and we then decompress the file

    tar -xvf DPO_RT3290_LinuxSTA_V2600_20120508.tar.gz
  2. Go inside the newly created folder:

    cd ~/DPO_RT3290_LinuxSTA_V2600_20120508

    and we start the compiling process

    sudo make install
  3. We then test to see if the driver is correctly compiled and installed

    sudo modprobe rt3290sta
  4. If step 3 runs without any problems we then add the module to the list of modules to loaded upon every boot:

    sudo -H gedit /etc/modules

    and add a line at the bottom that says rt3290sta. Save and exit.


Some users mention additional steps. This might or not apply to you. If you feel the system is not working, maybe one of the points below can help you along the way:

  • When opening the config.mk file, do not only change the HAS_NATIVE_WPA_SUPPLICANT to a value of y, but also do it with HAS_WPA_SUPPLICANT in case it has n. In my case it had y but it should be checked to make sure both WPA_SUPPLICANT are set to `y.

  • Blacklisting conflicting wireless drivers. Do the following:

    sudo -H gedit /etc/modprobe.d/blacklist.conf

    Add the following lines (Make sure they are not there in the first place):

    #Wireless drivers conflicting with rt3562sta  
    blacklist rt2800pci  
    blacklist rt2x00pci
  • Update initramfs: sudo update-initramfs -u

  • If you have trouble compiling the driver on Ubuntu 13.04 or Ubuntu 13.10 (and perhaps later versions as well), then this may be because of a change to the Linux kernel creating an incompatibility with the driver code. This can possibly be fixed by opening

    gedit os/linux/pci_main_dev.c

    and adding the following after the "#include " near the top

    #define __devexit
    #define __devinit
    #define __devinitdata

    then change the portion of the file which says

    #if LINUX_VERSION_CODE >= 0x20412 
    remove:     __devexit_p(rt2860_remove_one), 
    remove:     __devexit(rt2860_remove_one), 


    remove:     rt2860_remove_one,
    #if LINUX_VERSION_CODE >= 0x20412 
    remove:     __devexit_p(rt2860_remove_one), 
    remove:     __devexit(rt2860_remove_one), 

This will hopefully solve the compiler error. Return to the DPO_RT3290_LinuxSTA_V2600_20120508 directory and follow the instructions as above.

  • 1
    this driver is dropping connection from time to time, and that is why I think it is not good. But it is still better then what is currently installed, since it at least work, and it provides good signal Commented Mar 1, 2014 at 18:19
  • @BЈовић thanks for feedback friend and yes, it drops connection from time to time. Commented Mar 1, 2014 at 19:36
  • 1
    Kernel 4.10 lowlatency. Confirmed works for RT3290LE. Ubuntu 17.04. No drops (yet). Commented Jun 1, 2017 at 16:07
  • 1
    @LuisAlvarado Yes, it works out of the box. Be aware though. If you disable Wifi through nm-applet then enable it, the Wifi AP list will disappear. Commented Jun 1, 2017 at 20:35
  • 1
    Worked well in Linux Mint Mate 18.2 as well on kernel 4.10.0-32-generic.
    – vikas027
    Commented Aug 13, 2017 at 13:35

For those of you who couldn't get WiFi to work even after following the above steps (including me), this is a simple and much welcome fix.

The problem is that the kernel has problems supporting the driver, fortunately, the latest stable kernel release fixes the bug and the WiFi works with the default drivers.

To download the 32-bit kernel packages

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-headers-3.12.0-031200-generic_3.12.0-031200.201311031935_i386.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-headers-3.12.0-031200_3.12.0-031200.201311031935_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-image-3.12.0-031200-generic_3.12.0-031200.201311031935_i386.deb

To download the 64-bit kernel packages

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-headers-3.12.0-031200-generic_3.12.0-031200.201311031935_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-headers-3.12.0-031200_3.12.0-031200.201311031935_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-saucy/linux-image-3.12.0-031200-generic_3.12.0-031200.201311031935_amd64.deb

To install the packages

sudo dpkg -i linux-headers-3.12.0-*.deb linux-image-3.12.0-*.deb
sudo update-grub
sudo reboot

And that should do it.

In case if you want to remove the kernel

sudo apt-get purge linux-image-3.12.0-* linux-headers-3.12.0-*
  • This works! I installed Ubuntu 13.10 on my new HP Envy j049tx (flipkart.com/…). Compiling the Ralink driver manually worked but started causing kernel panics. Once i upgraded the kernel it works without issues. Thanks!
    – Adil
    Commented Jan 2, 2014 at 18:21
  • The dropbox guide and updating the latest kernal from browsing kernel.ubuntu.com/~kernel-ppa/mainline works smooth now.
    – Lalith B
    Commented Mar 17, 2014 at 6:40
  • kernel packages not found (404)
    – TomSawyer
    Commented Jul 30, 2016 at 22:51
  • If nothing else works see onthim.blogspot.co.ke/2015/06/… to download new drivers for the rt3290
    – Jonathan
    Commented May 26, 2017 at 10:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .