This question already has an answer here:

I was so stoked, it's been my best linux experience to date. Everything was running grandly, til I let the updates do there thing, post reboot only one display worked which was labeled as laptop and the second display would not respond.

I found instructions to remove and re-install, doesn't work (though it's back to two monitors they display at 640x480 which I can't change) (That post is located here Ubuntu 12.10 won't display properly after kernel upgrade)

sudo modprobe nvidia

tells me 'Fatal module not present'

I'd rather not start from scratch again this weekend, so suggestions would be greatly appreciated.

marked as duplicate by Eliah Kagan, desgua, Nathan Osman, Seth, hhlp Feb 11 '13 at 12:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Welcome to Ask Ubuntu! This question will probably be closed as a duplicate soon. If those answers don't fully address your question please edit it to include why and flag this for re-opening. Thanks! – Seth Feb 11 '13 at 1:45

You need to install the linux-headers-generic and linux-source packages so the nvidia proprietary drivers can install properly.

  1. Get into login screen after booting.

  2. Press Ctrl+Alt+F1.

  3. Login with your username/password and run the following commands:

    sudo apt-get purge nvidia-*

    sudo apt-get install linux-source

    sudo apt-get install linux-headers-generic

    sudo apt-get install nvidia-(whatever version you want to install) nvidia-xconfig

    sudo shutdown -r now

You may have a weird post-grub screen (plymouth) but that is another bug. It should let you now login and setup your dual display properly.

You can also try Ctrl+Alt+T to open a terminal right after logging and so typing

software-center -> Will open ubuntu software center so you can install sources and headers-generic software-properties-gtk -> Then navigate to other drivers and get back to Nouveau drivers or install whatever nvidia proprietary driver you want.

  • Hi. thanks for that seems to have worked, One thing that was interesting is the last step nvidia-xconfig just throws an error, yet rebooting post the rest seemed to work out okay, maybe I mis-understood and (nvidia-xconfig) was meant to be part of the install command? – user130087 Feb 11 '13 at 0:22
  • No, its not part I just messed with the lines. Just after the "... install nvidia-****", when it finishes, make nvidia-xconfig (should tell you about a file created /etc/X11/.. Anyways, its not a must-do as the driver would automatically do when hes selected to work from. – Toperharrier Feb 12 '13 at 23:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.