I'm trying to configure an Ubuntu 12.10 based server. My motherboard is an ASUS P8Z77-V Deluxe with WifiGo module onboard. I want to make it an access-point.

I have fought with it for a lot of time but always got the same error:

sudo iwconfig eth0 mode Master

Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth0 ; Invalid argument.

In one occasion I managed to create an Ad-hoc Network and connect the device to it, but trying to make the device into an access point has not been possible. Now I have a clean system and have only installed some packages (listed below). This is the current status right now:

After installing bcmwl-kernel-source and linux-headers-3.5.0-23-generic linux-libc-dev libc6-dev linux-headers-generic, wl module appears in lsmod. There is no conflicted modules like ssb, or b43.

eth0 device by sudo iwconfig eth0 gives me:

IEEE 802.11abgn  ESSID:""  
Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
Bit Rate:144 Mb/s   Tx-Power:24 dBm   
Retry min limit:7   RTS thr:off   Fragment thr:off
Power Managementmode:All packets received
Link Quality=5/5  Signal level=0 dBm  Noise level=-9 dBm
Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Tx excessive retries:0  Invalid misc:0   Missed beacon:0

iwlist s command successfully finds wifi networks around.

Maybe someone can tell me what else should I do, I'm totally confused.

Short answer: I didn't manage to run master mode on it. I will look for another adapter.

Extended answer:
First about broadcom-wl solution. It's pretty easy make your adapter work as client, but tottaly impossible to run master mode. It's described at wikidevi.

About ndiswrapper I can say only one thing. It isn't support master mode.
firmware-b43-installer says This card is actually not tested. Please install the driver manually. After downloading and unpacking via b43-fwcutter (described at link), but no results. Driver is installed, lsmod shows loaded modules, but wi-fi card was unreachable.


I would first recommend reading this question and the answer provided: Installing Broadcom Wireless Drivers (Just to have the same driver install)

Second I would first try to look to see if this Broadcom Wireless card, using the wl module, supports Ad-hoc mode. For example, in the wiki about broadcom modules I can see this wireless card when using the wl module listed as not supporting Ad-Hoc, Monitor or even Injections. This does not mean it is permanent, it just means that the development of this card is not yet mature enough for this features (It will eventually have them). I happen to have a BCM4313 that has the same issue. I can connect to other devices, even Ad-Hoc ones, but I can not create an Ad-Hoc one.

Now, there might some changes looking into newer kernel versions. Since you are in the 3.5.x kernel version I can only add that:

In the kernel version 3.6.x, regarding the Network part, there were little updated to Broadcom cards.

In the kernel version 3.7.x, same as above, there were other updates to Broadcom cards.

There is a very good link regarding this Model created by izx that I mention in the link about installing Broadcom cards. His answer is here.

At the end, if you still have a wireless card that does not support Ad-Hoc, then you are like me, we would have to wait for future implementation of this (Or use a "modified" version of the driver.. injected or otherwise).

  • Thank you for answering and editing! I will try it, and post results a bit later. – Seagull Feb 10 '13 at 22:16
  • Much appreciated Seagull, results will help a lot in your case since I have had little experience with that model myself. – Luis Alvarado Feb 10 '13 at 22:30
  • At this point I tried use b43 and ndiswrapper, but without any success. Now wifi card is unreachable at all. I will continue work at this, tomorrow or little later. – Seagull Feb 11 '13 at 0:08
  • Reporting: I did not succeed in setting up my adapter. Sad, but at this moment there is no way to use it. Will wait an update. Thank you for answer again. – Seagull Feb 18 '13 at 18:22
  • @Seagull Hi buddy, can you edit your question to include all the steps you did and what you actually tried or send it to luisalvarado@ubuntu.com and I will add it to your question. That way is easier to follow up on you. – Luis Alvarado Feb 18 '13 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.