Also spikes in CP usage. I am sure it is not a memory issue since I have over 100gb for the Ubuntu OS. It was also giving me errors regarding my graphics card which I managed to correct(I think) before this started happening. . I've been trying to learn as much and as fast as I can but I am still a newbie and not as computer savvy as I would like to be as of yet. So I do not even know what tests to run to have information to give for someone to provide me an answer to this problem. Below is at least information about my server which I hope will be of some use to anyone who could help out or point me to a link with possible answers.

Thanking you in advance.

Had to uncomment most of results so they would not be enlarged and emboldened. Results of sudo(and gksudo) gedit /etc/default/grub

If you change this file, run 'update-grub' afterwards to update
For full documentation of the options in this file, see:
  info -f grub -n 'Simple configuration'





GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian'



Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)


Uncomment to disable graphical terminal (grub-pc only)


The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo'


Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux


Uncomment to disable generation of recovery mode menu


Uncomment to get a beep at grub start

GRUB_INIT_TUNE="480 440 1"

Also based on another link which said I should add in the i915 and intel_agp drivers(which I don't yet know how to add drivers that way and then save, and rebuild by running update-initramfs -u) I ran the command sudo gedit /etc/initramfs-tools/modules with these results:

List of modules that you want to include in your initramfs.They will be loaded at boot time in the order below.
Syntax:  module_name [args ...]

You must run update-initramfs(8) to effect this change.



Found these two links.

This one HERE! Specific to Ubuntu and the type of CPU(Intel) I have.

And this link HERE! Which I have quoted one of the answers from just below.

Im working through similar issues with my x230, but more focussed on getting external screens running. I had to use the nomodeset flag to get installed. Here is what I have so far: display port on x230 not working

My steps so far to get closer to working:

Don't use `nomodeset` or `modeset=0`, as it throws off KMS and you wont be able to do anything.
`sudo vi /etc/initramfs-tools/modules` and add in the i915 and intel_agp drivers, save, and rebuild by running `update-initramfs -u`.

I've also made a custom x config stub in /usr/share/X11/xorg.conf.d/ to load the Intel driver and give it some specifications, and a monitor config for all my devices. However, I still cant get my second monitor running!

Also - Ive used arandr to create a shell script that sets all my resolutions nicely, except it too wont cause my displayport-connected monitor to function...

Hope that helps.


It uses from 1/2 to 3/4 of CPU usage when first starting out and then continues to use around 1/2 of the CPU when virtually nothing is being run. And absolutely refuses to shut down the vast majority of the time even when trying to get a terminal by pressing Alt Ctl Del or Alt Ctl Del and then Ctl Atl Backspace. Everything just freezes up. Will now try what you have suggested, jwpat7.

    tom@ubuntu12:~$ lspci -vk | grep -iA10 vga
    01:00.1 VGA compatible controller: Matrox Electronics Systems Ltd. MGA G200EH (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device 330e
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at f9000000 (32-bit, prefetchable) [size=16M]
        Memory at fbde0000 (32-bit, non-prefetchable) [size=16K]
        Memory at fb000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>

    01:00.2 System peripheral: Hewlett-Packard Company Integrated Lights-Out Standard Management Processor Support and Messaging (rev 05)
        Subsystem: Hewlett-Packard Company iLO3

    tom@ubuntu12:~$ sudo lshw -C processor
    [sudo] password for tom:
           description: CPU
           product: Intel(R) Xeon(R) CPU E31220 @ 3.10GHz
           vendor: Intel Corp.
           physical id: 400
           bus info: cpu@0
           version: Intel(R) Xeon(R) CPU E31220 @ 3.10GHz
           slot: Proc 1
           size: 3100MHz
           width: 64 bits
           clock: 100MHz
           capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
           configuration: cores=4 enabledcores=4 threads=4

    tom@ubuntu12:~$ free -m df -h
                 total       used       free     shared    buffers     cached
    Mem:          1.9G       1.8G        73M         0B        76M       535M
    -/+ buffers/cache:       1.2G       686M
    Swap:         2.2G        10M       2.1G

Main Computer  

Brand - HP   
Series - ProLiant ML110 G7   
Model - 626474R-001   
Type - Tower   
Processor - Intel Xeon E3-1220 3.1GHz 4C/4T (8 MB Cache 80W)   
Memory - 2GB DDR3 (Max 16 GB / 4 DIMM slots / Unbuffered ECC )   
Hard Drive - 1 x 250GB Non-hot-plug LFF SATA   
Storage Controller - HP Embedded Smart Array B110i SATA RAID Controller   
Raid Level - RAID 0/1/10   
Max HDD Capacity - Up to 8.0TB (4 x 2.0TB) Non-hot plug LFF SATA   
Media Drives - HP Half-Height 16x SATA DVD-ROM   
Networking - HP NC112i 1-Port Ethernet Server Adapter (x2)   
Expansion Slots - 4   

Power - (1) 350 Watt non-hot plug, non-redundant   
  One (1) - Non-redundant system fan ships standard   
  One (1) - Non-redundant PCIe fan ships standard   
  One (1) - Non-redundant CPU heatsink fan ships standard   

  Management: HP Integrated Lights-Out Standard (iLO 3)   
  • I'm not quite sure what your situation is here. Are you saying you've installed Ubuntu Server on your computer and are now running a graphical interface in it?
    – user2405
    Feb 10, 2013 at 19:31
  • Chris, I have had Ubuntu 12.04 installed for about 7 months now which has been running my server and making my privately run WordPress site visible on the Internet. And except for occasionally using the command line, yes I do run the server with a graphical interface. Do you think it is a mistake to do that? I haven't had any real problems until the upgrade to 12.10.
    – user92217
    Feb 11, 2013 at 5:33
  • It's not a common thing to run a graphical interface on a Linux server so I just wanted to be sure :)
    – user2405
    Feb 11, 2013 at 10:31
  • I see a recent edit mentions i915.modeset. I was assuming i915 isn't relevant to the ProLiant ML110 G7. If the i915 is relevant, note that I installed an Ubuntu 12.04 LTS system on another person's computer a couple of weeks ago and had to use i915.i915_enable_rc6=0 to avoid screen freezing (even though some ubuntu pages imply the i915_enable_rc6 problem was fixed a year ago). Feb 11, 2013 at 21:07
  • I see an answer saying "Solved". Has this been resolved?
    – Seth
    Mar 5, 2013 at 16:21

2 Answers 2


Among other reasons, this can be caused by using an incorrect video driver, or incorrect video settings. Try selecting a default mode, as described in a linuxmint article which applies to drivers with a modeset parameter. I've quoted part of the article below, but for more background see the article itself. The general idea is to tell grub to temporarily (ie, for the current boot) turn off video features that may be causing problems. If turning those features off alleviates the symptoms, then do a web search concentrating on the video card features that were turned off. When the system is running, you can also make parameter changes permanent by editing /boot/grub/menu.lst or perhaps /etc/default/grub as described elsewhere (1, 2, 3, 4).

From the linuxmint article:

• Reboot and wait to see the initial boot screen of GRUB with a list of operating systems. Tap a cursor key to avoid automatic boot.
• Select your choice ... with the cursor and then press the [tab] key to get the full boot grub commad line.
• Go to the line starting with the word linux and ending with the words: quiet splash
• [Add a modeset=0 parameter] at the end of the long grub command line [...] Use the parameter related to the brand or chipset of your video card [eg] use nouveau or nvidia for nvidia based cards ... use radeon for amd/ati cards, i915 for intel based motherboards, [eg]


• If you don't know the brand you may use just one word: nomodeset
• Press [Ctrl]+[X] to boot with this added parameter. This parameter will not be saved, just used in this single boot and nothing is damaged. To cancel without changes press [Esc].

  • jwpat7, thanks tremendously for your answer. I will try all of that. Also I finally managed to find some tests to run on my system. The results are in my original question in case any of that information would be of further use to you. And once again thank you so much for this help. Zen ;-)
    – user92217
    Feb 11, 2013 at 5:11
  • Hope you are still around. I have gone into the grub command line for both Ubuntu and Ubuntu Advanced Options. Neither has a line starting with "linux' which ends with the words: quiet splash. Most end in a long list of letters and numbers. So unless I am in the wrong area, I tend to think "quiet splash" is particular to linuxmint. I found 2 lines in grub command of Ubuntu Advanced Options which already have nomodset(which is universal) so I am reluctant to change them based on information from another link I found which I have placed in my original question. Very confused rt now.
    – user92217
    Feb 11, 2013 at 19:37
  • No, quiet splash also is used by grub for ubuntu. For example, grep splash /etc/default/grub on my Ubuntu 12.04.1 LTS system shows: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (Note, don't make any changes in /etc/default/grub unless you have already tested them during boot with grub.) Anyway, did you see Matrox or MGA or G200EH anywhere in grub stuff? linux.die.net shows some mga options and driver names but I don't know how to specify them during booting. Feb 11, 2013 at 20:54
  • Myfriend, I have used both sudo(and gksudo) gedit /etc/default/grub with the results I have posted above at beginning of origianl post. Neither shows "quiet splash" nor Matrox or MGA or G200EH. Still trying to solve this problem which I now think and HOPE may only need some minor tweaking but I don't know where. Will be forever in your debt if you can help just a bit more. ;-)
    – user92217
    Feb 12, 2013 at 19:09
  • @jwpat7Relative success! I put "quiet splash" between the quotes at the end of the line: GRUB_CMDLINE_LINUX_DEFAULT=""
    – user92217
    Feb 12, 2013 at 21:12

SOLVED! I took a chance and did a clean install of Ubuntu 12.10 from an iso image I burned to disc. Now everything works even better than it did before! And OMG Ubuntu 12.10 what a fantastic new look along with a bunch of nice new bells and whistles! The fresh instill is ENTIRELY different than what I had with just the upgrade to vs 12.10. Congratulations to all of you who worked on it. BTW, everywhere in the documentation it DOES say to make a fresh install of Ubuntu 12.10 rather than just doing an upgrade since SNAFU's are more apt to take place from doing a "lazy" upgrade. I am just so happy that I did take the chance on the fresh install of vs 12.10 rather than just playing it safe and doing another fresh instillation of Ubuntu 12.04 to try and correct the errors that occurred during the sloppy upgrade process and which are now not present. Zen

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.