I installed bumbulbee drivers by running the following commands:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic

and then checked the configuration by running:

sudo optirun nvidia-settings -c :8

and checked for all the setting which appeared fine. But then when I rebuilt the xorg.conf file by running:

sudo nvidia-xconfig
restart lightdm

and after that when I restarted the system. X server failed to start resulting in blank screen. When tried starting Xserver by pressing Ctrl + Alt + F1, startx failed to start (gives the error), so when I removed /etc/X11/xorg.conf the system started off well again but it seems that when ever I try to run Counter Strike 1.6 by optirun through wine by:

env WINEPREFIX="/home/ph3n1x/.wine" optirun wine C:\\"Program Files"\\"Counter-Strike 1.6"\\hl.exe

it fails with the error:

X Error of failed request:  BadMatch (invalid parameter attributes)
Major opcode of failed request:  135 (GLX)
Minor opcode of failed request:  26 (X_GLXMakeContextCurrent)
Serial number of failed request:  254
Current serial number in output stream:  254

My lspci shows:

01:00.0 VGA compatible controller: nVidia Corporation Device 1058 (rev ff)

So I can't figure out what exactly is the problem and what can be the solution to it. Please any help.

  • Run the game with the HL.exe and switch to Counter Strike then modify the video setting to 32bit 1024x768 resolution it will work flawless – Arush Salil Feb 16 '13 at 14:21

I have had to change the ownership of the file .Xauthority . I went through a cycle of failure when a screen saver locked up my X server. I killed the session, re-booted, and the desktop refused to start for my account only. I started another account, opened a terminal and changed to my account using the 'su' command:

su - myaccount

I could log in as myself.


I looked at my home directory -

ls -lrt |tail 

-rw------- 1 root root 107 Feb 17 10:16 .Xauthority

and found that the .Xauthority account was owned by root.

To Change ownership of a file

I changed the ownership with

sudo chown myaccount:myaccount .Xauthority

I confirmed the ownership change with ' ls -lrt |tail ' and then logged in as myself.

-rw------- 1 myaccount myaccount 107 Feb 17 10:16 .Xauthority

All better!

Typically files that begin with a dot and in your home directory should belong to yourself. AND you would never log in as root, right?

| improve this answer | |
  • Well the problem of not being able to login was easily solved as I simply just deleted my Xauthority file and rebooted the real problem is that although at every single point my system is recognizing my 2nd GPU - nVIDIA 630m but when I try to default start my X server with it,it simply crashes and refuse to start. More with that I am not able use my GPU even by the optirun run command. – Arush Salil Feb 22 '13 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.