2

I am dual-booting my laptop going between Windows 7 and Ubuntu 12.04 LTS. Initially, I can connect to WiFi, but if I get disconnected for some reason, or if I restart my router, Ubuntu won't reconnect unless I reboot my laptop. Just logging out and back in won't work, I have to restart ubuntu, why and how can I fix this?

The output of sudo lshw -c network is

*-network
description: Wireless interface product: BCM4313 802.11b/g/n Wireless LAN Controller vendor: Broadcom Corporation physical id: 0 bus info: pci@0000:04:00.0 logical name: eth1 version: 01 serial: e4:d5:3d:77:df:9d width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) ip=192.168.1.105 latency=0 multicast=yes wireless=IEEE 802.11abg resources: irq:16 memory:c2500000-c2503fff *-network description: Ethernet interface product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller vendor: Realtek Semiconductor Co., Ltd. physical id: 0 bus info: pci@0000:05:00.0 logical name: eth0 version: 05 serial: ec:9a:74:48:ce:63 size: 10Mbit/s capacity: 100Mbit/s width: 64 bits clock: 33MHz capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s resources: irq:44 ioport:3000(size=256) memory:c0404000-c0404fff memory:c0400000-c0403fff

I have installed Broadcom STA wireless driver. I have experienced the same issue before with other distros; Crunchbang doesn't connect to wireless at all, Archbang won't connect to wireless after upgrading pacman. The problem began with Ubuntu, which is why I tried both Crunchbang and Arch and then ended back at Ubuntu.

The output of:

lsmod

cat /etc/modules

cat /etc/modprobe.d/blacklist.conf

  • I have the opposite problem. This never happened under 14.04 LTS for me. The upgrade to 16.04 LTS is so great I'll keep it, but it keeps forgetting my WiFi password. The service is clearly running; just that it forgets the password and doesn't connect. I posted this: askubuntu.com/questions/934958/… - and I do not want to deal with blacklisting or anything strange. – SDsolar Jul 11 '17 at 3:59
3

Please provide the output of the following commands

lsmod
cat /etc/modules
cat /etc/modprobe.d/blacklist.conf

If you have b43 module running try blacklisting it and use the module wl or brcmsmac

vim /etc/modprobe.d/blacklist.conf

add the following line to this file

blacklist b43

save the file

vim /etc/modules

add the following line to this file to load wl at boot time

wl

restart your pc

if it doesn't work

try reinstalling drivers using jockey

  • please read my edit – Lynob Feb 10 '13 at 0:18
  • did you try blacklisting the b43 module and adding wl module to the list of modules to be loaded at boot time – Abhishek Kandoi Feb 10 '13 at 0:27
  • dpaste.com/917798 see line 35, it says blacklist bcm43xx so it's already blacklisted right? aren't you talking about that module? – Lynob Feb 10 '13 at 0:30
  • no bcm43xx module was used in older versions of linux, blacklist b43 and add wl module to list of modules to be loaded at boot time and try again – Abhishek Kandoi Feb 10 '13 at 0:32
  • wl didn't work but it seems that brcmsmac is working! Will that solve the issue with crunchbang or arch? – Lynob Feb 10 '13 at 13:45
0

Windows is turning off your wireless adapter thus working only when you turn on your computer. You need to turn off the power management feature. You do this through the control panel.

Start your control panel Click on Network and Internet Click on View network status In the upper left side click on Change adapter settings Right click on your wifi icon In the drop down box click on Properties Under the Connect Using heading click on configure In the new box click the tab on the right Power Management Unclick the Allow computer to turn off the device to save power button

Click save and close all windows Restart your computer

0

Temporary Fix - so that you don't have to restart your system. Try:

sudo service network-manager restart

It restarts your network-manager which could solve your problem

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.