I bought new computer. The Graphics card is AMD Radeon HD 6450, on Windows 7 it works fine but I try to install driver on Ubuntu, and it says that "No supported adapters detected". I downloaded the driver from here. After installing "Aditional drivers" says that driver is installed. Also my screen resolution in Ubuntu is not maximum. Can you help me install proper driver, please? Thanks in advance!

  • What is the output from fglrxinfo, lshw -C video, and glxinfo? Verifying a proper install: wiki.cchtml.com/index.php/Verifying To install: wiki.cchtml.com/index.php/Category:Installation_Documentation Feb 8, 2011 at 21:28
  • do you have "ATI catalyst control" in your preferences menu?
    – Allan
    Feb 8, 2011 at 21:30
  • fglrxinfo = command not found
    – vanysha
    Feb 8, 2011 at 22:21
  • lshw -C video = *-display description: VGA compatible controller product: ATI Technologies Inc vendor: ATI Technologies Inc physical id: 0 bus info: pci@0000:01:00.0 version: 00 width: 64 bits clock: 33MHz capabilities: pm pciexpress msi vga_controller bus_master cap_list rom configuration: driver=fglrx_pci latency=0 resources: irq:18 memory:d0000000-dfffffff memory:fe9e0000-fe9fffff ioport:d000(size=256) memory:fe9c0000-fe9dffff
    – vanysha
    Feb 8, 2011 at 22:21
  • glxinfo = name of display: :0.0 X Error of failed request: BadRequest (invalid request code or no such operation) Major opcode of failed request: 136 (GLX) Minor opcode of failed request: 19 (X_GLXQueryServerString) Serial number of failed request: 14 Current serial number in output stream: 14
    – vanysha
    Feb 8, 2011 at 22:22

5 Answers 5


I had a similar problem, but it worked fine for the previous version of this driver: "AMD Catalyst™ 11.8 Proprietary Linux x86 Display Driver". Here are the steps to download and install it:

  • Download the AMD Catalyst™ 11.8 Proprietary Linux x86 Display Driver
     wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-8-x86.x86_64.run
    If you don't have 'wget', install it by
     sudo apt-get install wget  
  • Make it executable, if not already

     chmod +x ati-driver-installer-11-8-x86.x86_64.run 

  • Run it and follow on-screen instructions to install the driver

     sudo ./ati-driver-installer-11-8-x86.x86_64.run 

Hope this helps!

  • Do it in Debian mode:

    sudo aptitude install xserver-xorg-video-ati
  • Or download the generic driver here:


Then go to another console (CTRL+ALT+F2), log in as root, shut down X (/etc/init.d/gdm stop), install the driver, and restart your box.

  • Nothing changed... Catalist control center does not work.
    – vanysha
    Feb 8, 2011 at 22:17
  • Is your box 32-bit or 64-bit? Please post the result of:sudo lspci | grep VGA.
    – 象嘉道
    Feb 8, 2011 at 23:01
  • My Ubuntu is installed from the original CD that Canonical send to me, so it's x32. sudo lspci | grep VGA = 01:00.0 VGA compatible controller: ATI Technologies Inc Device 6779
    – vanysha
    Feb 8, 2011 at 23:08
  • Remove the current installed driver firstly: sudo aptitude remove xserver-xorg-video-ati. And then install the generic driver. You had better do them after shutting down X: sudo /etc/init.d/gdm stop (if you use gnome).
    – 象嘉道
    Feb 9, 2011 at 17:19
  • I done exactly the same... The driver does not work.
    – vanysha
    Feb 13, 2011 at 13:40

You should say which version of Ubuntu you're using. In 11.04, the open radeon driver should work well, though not perfectly. In 11.10, it's been improved further, and I much prefer it to the proprietary driver for my HD 5850. It's faster and it's easier to deal with.


I had the same problem, and also another one that you seem to also have at the same time: a big annoying AMD Unsupported Harware icon. As a consequence, when I tried to install Ubuntu 10.10, it froze just after the login screen and when I tried to install Ubuntu 11.10, it did not even arrive to the login screen.

Here is what I did, which solved the problem:

  • using another computer, download the latest proprietary driver from ATI on the official site. In my case I had to download it from here.
  • put the driver on a USB key
  • reboot the computer we want to repair
  • in the grub menu, select the recovery mode. This results in arriving at a command line interface. This is a proof that the Ubuntu operating system is functioning but that the problem is indeed the graphical card.
  • uninstall all previous versions of flgrx by launching sudo apt-get remove flgrx for example
  • mount the USB key with something close to mkdir /mnt/usb followed by sudo mount /dev/sdb /mnt/usb. Another way for this little step is explained here.
  • use the cd command to place yourself in the folder where the downloaded driver is
  • if necessary, make the driver be executable with something like chmod +x ./ati-driver-installer-11-11-x86.x86_64.run
  • execute the driver using sudo ./ati-driver-installer-11-11-x86.x86_64.run
  • follow the instructions given on the installer
  • if this step did not work, you may want to try sudo ./ati-driver-installer-11-11-x86.x86_64.run --force instead
  • reboot your computer

Then your two problems should both be solved!


Just managed to get the above card to work on my device, running 12.04, 64-bit. I started by following the suggestions here, none of which appeared to work in my case.

The device already had a video card (Matrox VGA) which was working fine. Wanted to add this to support dual monitors. When I added the AMD Radeon HD 6450 then I would get a blank screen. (Output from the Radeon was colored pixels with no sign of response from keyboard). I would bypass the blank screen with Ctrl-Alt-F2 to get a terminal up, which displayed as expected.

Output from fglrxinfo was command not found.

The link referred to by vikram appears no longer to be working and has moved to that referred to by Agmenor. I followed those instructions and it told me install had completed, so rebooted and same situation as above.

Ultimately I followed the instructions here on the Official Documentation which I will repeat briefly. These were run line-by-line as sudo:

### backup configuration file
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.BAK
### in case already installed
apt-get remove --purge fglrx fglrx-amdcccle fglrx-updates fglrx-amdcccle-updates
apt-get install -y fglrx fglrx-amdcccle
aticonfig --initial
### now check it's working
### connect video out to new video card
### add video acceleration
apt-get install -y xvba-va-driver libva-glx1 libva-egl1 vainfo

This is good enough for me. The boot output still goes to the Matrox and the Radeon output is blank until X starts.

Not the answer you're looking for? Browse other questions tagged or ask your own question.