How to copy & paste with VirtualBox from Ubuntu (host) to Ubuntu (guest)?

I installed virtualbox guest edition on Ubuntu [guest] system. But still its not working. If anyone can have some solution then please share it.

  • 2
    To close voters: This is not the same as that question, where the solution is to install the VirtualBox Guest Additions; the OP here has told us s/he's already done that. darkshbhatt21: Does it work if you make sure to keep the program containing the text on the host open? And does it work the other way around--can you copy in the guest and paste the copied text in the host? What version of Ubuntu is running on each, and (if you know) what interface? (For example, are they both running Unity, Unity 2D, Xfce...) Feb 9, 2013 at 9:56
  • Host = Ubuntu 12.10, Guest = Ubuntu 12.10, both working Unity and 32-bit, I can copy-paste files from host to guest and vice-versa but I can not copy text, From gedit [on host] to gedit or terminal [on guest] Apr 1, 2013 at 5:14
  • Still experiencing the same problem? With Ubuntu 13.10 and latest VirtualBox?
    – Braiam
    Nov 28, 2013 at 19:41
  • @Braiam I'm experiencing the problem with 13.04 and the latest VirtualBox (and the latest extensions).
    – Pointy
    Mar 9, 2014 at 19:09
  • @Pointy 13.04 is EOL, use 13.10 and test.
    – Braiam
    Mar 9, 2014 at 19:12

1 Answer 1


Open up the VirtualBox Manager, select your guest machine, and go to Settings. In General, there should be a tab called "Advanced". Make sure "Shared Clipboard" is set to "Bidirectional".

  • Similar answer askubuntu.com/a/184714/46709
    – Bryce
    Jan 3, 2014 at 20:58
  • 1
    This is apparently something that needs to be done, but it does not necessarily fix the problem.
    – Pointy
    Mar 9, 2014 at 19:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .