This question already has an answer here:

My son bougt a laptop. I installed Ubuntu 12.04. First wifi worked fine now it keeps searching but can't connect. I tried some solutions but I think I need help.

lspci -nn | grep 028002:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

These are the data. Thanks!

marked as duplicate by Luis Alvarado, Eliah Kagan, Eric Carvalho, Nathan Osman, hhlp Feb 9 '13 at 10:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have you tried search for the propriotary drivers? They might show up there. – user129350 Feb 8 '13 at 23:55

Please get a temporary wired ethernet connection and open a terminal and do:

sudo apt-get install linux-firmware-nonfree

Reboot and you should be all set.

  • Thanks for your help. I did that. Now I can connect but the connection is weak. There is a special driver for the BCM4313 that I find in the "extra driver" section. When I install that wifi isn't connecting. I read in ubuntu forums that 12.10 does a better job with Broadcom so I'm going to install that. I'll let you know. – Albert Weijers Feb 9 '13 at 8:10
  • Hi, I installed 12.10 64 bit and it works fine now! It recognizes the Broadcom BCM4313 and installs it correctly. After that I installed Minecraft and the updates and after reboot.. no wireless at all! I installed 12.10 again without updates, now it works fine. I'm afraid to install updates now. So I won't do that until it's nessecary. – Albert Weijers Feb 9 '13 at 12:06
  • Which driver is it using successfully in 12.10? b43 or wl? Find out with: lsmod – chili555 Feb 9 '13 at 13:36
  • Hi, lsmod give me a whole list, these are the lines that include 'wl'. Thanks! wl 2573568 0 bluetooth 209199 11 rfcomm,bnep,btusb lib80211 14381 2 lib80211_crypt_tkip,wl – Albert Weijers Feb 14 '13 at 10:30
  • I think it will work fine if you install linux-headers-generic and then update. The update should then install a newer bcmwl-kernel-source, if available, and linux-headers and I suspect you'll be fine. – chili555 Feb 14 '13 at 15:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.