I was able to connect to the wireless 'AirportFaustin' and others using network icon dropdown menu. I decided to switch from proprietary to open drivers for my wireless card drivers. Once I done it offline.

Since then 'AirportFaustin' wireless network is missing in the network icon dropdown menu. Others are here and work.

  • I tried menu item connect to hidden network : I'm still unable to connect. Ubuntu ask again the key.
  • Now (I don't know before) this network is listed in the network manager.
  • This network is allowed for all users.
  • On my computer and others on OSX, I can see and connect without issue to that network.

I would like to be able again to connect to this and others (all) network and that from the network icon dropdown menu.

My issue is different from My wireless network not visible in wireless network list with a Broadcom card because I was able to connect to that network before and I change my network configuration (switch open/proprietary).

I'm using a MacBook Air 4,2 with Ubuntu 12.04.1 LTS and try to connect to a wireless network on a Apple Airport Express (that has been reset to factory config).

I've applied the post-install script on the MacBookAir4-2 page.

I checked /etc/modprobe.d and found two files (the second is directly made by the script. I remember having seen dkms while running the screen too in the Terminal) that blacklist wireless modules :

  1. broadcom-sta-dkms.conf

    # wl module from Broadcom conflicts with the following modules:
    blacklist b44
    blacklist b43legacy
    blacklist b43
    blacklist brcm80211
    blacklist brcmsmac
    blacklist brcmfmac
    blacklist ssb
    blacklist bcma
    blacklist bcm43xx
  2. blacklist bcma.conf

    blacklist bcma

Following the HOWTO post a Wireless issue, my config is :

lspci -nn | grep Broadcom
02:00.0 Network controller [0280]: Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)

iwconfig wlan0
wlan0     IEEE 802.11  Access Point: Not-Associated   
          Link Quality:5  Signal level:201  Noise level:166
          Rx invalid nwid:0  invalid crypt:0  invalid misc:0

Module                  Size  Used by
michael_mic            12612  4 
arc4                   12529  2 
usbhid                 47238  0 
snd_hda_codec_hdmi     32474  1 
snd_hda_codec_cirrus    28098  1 
snd_hda_intel          33773  3 
snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_cirrus,snd_hda_intel
snd_hwdep              17764  1 snd_hda_codec
snd_pcm                97275  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi           13324  0 
snd_rawmidi            30748  1 snd_seq_midi
joydev                 17693  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61929  2 snd_seq_midi,snd_seq_midi_event
snd_timer              29990  2 snd_pcm,snd_seq
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
applesmc               19554  0 
input_polldev          13896  1 applesmc
lib80211_crypt_tkip    17390  0 
wl                   2623795  0 
bcm5974                17399  0 
snd                    79041  16   
cfg80211              205774  1 wl
lib80211               14381  2 lib80211_crypt_tkip,wl
btusb                  18332  1 
uvcvideo               72627  0 
videodev               98259  1 uvcvideo
i915                  477602  3 
v4l2_compat_ioctl32    17128  1 videodev
drm_kms_helper         46978  1 i915
drm                   241971  4 i915,drm_kms_helper
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
mei                    41616  0 
i2c_algo_bit           13423  1 i915
mac_hid                13253  0 
video                  19596  1 i915
apple_bl               13673  0 
coretemp               13525  0 
bnep                   18281  2 
parport_pc             32866  0 
ppdev                  17113  0 
rfcomm                 47604  12 
bluetooth             180153  23 btusb,bnep,rfcomm
binfmt_misc            17540  1 
lp                     17799  0 
parport                46562  3 parport_pc,ppdev,lp
hid_apple              13375  0 
hid                    99636  2 usbhid,hid_apple

sudo lshw -C network
   description: Interface réseau sans fil
   produit: BCM43224 802.11a/b/g/n
   fabriquant: Broadcom Corporation
   identifiant matériel: 0
   information bus: pci@0000:02:00.0
   nom logique: wlan0
   version: 01
   numéro de série: b8:8d:12:08:12:4c
   bits: 64 bits
   horloge: 33MHz
   fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=wl0 driverversion= ip= latency=0 multicast=yes wireless=IEEE 802.11abgn
   ressources: irq:17 mémoire:a0400000-a0403fff

iwlist scan
lo        Interface doesn't support scanning.
wlan0     Interface doesn't support scanning.

lsb_release -d
Description:    Ubuntu 12.04.1 LTS

uname -mr
3.2.0-36-generic x86_64
  • Do someone need more/different info to help me solving this issue ?
    – NicolasWeb
    Feb 11, 2013 at 16:20
  • why do you need open drivers?
    – jasmines
    Feb 11, 2013 at 16:39
  • I don't need it : I prefer it because of my convictions. But now that I (already) tried switching drivers, I have the described issue using the open/free and proprietary. ;-)
    – NicolasWeb
    Feb 11, 2013 at 16:53
  • Could deleting the network manager known wireless network file help ? (witch one is it please ?) SO I can know if it's a bug or a corrupted file...
    – NicolasWeb
    Feb 19, 2013 at 10:22

2 Answers 2


Source: http://www.intervigil.net/?tag=bcm43224

The one thing NOT covered by the Ubuntu community wiki is the wireless driver. The MacBook Air 4,1 has a Broadcom BCM43224 chip, which is actually covered by several different drivers, b43 (if you hack around a bit), brcmsmac, and the wl Broadcom STA driver (closed source). Poking around seems to suggest that the best option is the brcmsmac module, as it is based off the open-sourced driver that Broadcom released late 2010, however owing to it’s immaturity, it still lives in the staging drivers section of the Linux kernel. It also seems to lack some features supported by the Broadcom STA drivers, namely power management, which is the main reason why I chose to use the closed source (the horror) Broadcom STA drivers available from the Ubuntu “restricted” repository under the brcmwl-kernel-source package.

The one item to note with this module is that the brcmwl-kernel-source package actually doesn’t have an updated blacklist file in /etc/modprobe.d, and will fail to blacklist the brcmsmac module available by default, potentially leading to problems. I had to add brcmsmac and bcma to the blacklist with the following:

sudo sh -c "echo 'blacklist brcmsmac' >> /etc/modprobe.d/blacklist-b43.conf"
sudo sh -c "echo 'blacklist bcma' >> /etc/modprobe.d/blacklist-b43.conf"

This prevents the kernel from loading both drivers.

More about your issue: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=698697

  • Thanks for these precisions on the context about drivers, even if it don't explain how to solve the missing wireless network in network menu yet. I added info : bcma is already blacklisted by a script. However, lsmod don't say that these modules are loaded. It seems to me that the drivers used is wl or bcm5974, right ?
    – NicolasWeb
    Feb 11, 2013 at 19:01

I had to change my wifi radio channel to channel 9, and it magically appears on the network dropdown. It may possibly be a collision with another wifi network using the same channel or a bug. It displays for me now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .