48

I have shutter 0.90 on my Ubuntu 12.04 machine (installed via PPA). I would like to use it as my default screenshot tool with the Print shortcut key. But I can't find the option in Shutter. It should be in Preferences -> Keyboard, but I don't see the Keyboard option there. I also tried to make a shortcut in Ubuntu with shutter -f. It doesn't work too.

What can I do to use shutter when I press the Print key?

28

We need to install CompizConfig Settings Manager (CCSM) to bind Print and Alt + Print to Shutter. Follow these steps:

  1. Install compizconfig-settings-manager Install compizconfig-settings-manager.

  2. Open Dash (press Super) and query for ccsm and hit Enter to run CompizConfig Settings Manager.

    ccsm in Dash

  3. Under the General Category, you would find the option called Gnome Compatibility. Click on it (not the Checkbox beside it, ie; keep the checkmark activated).

    General >> Gnome Compatibility

  4. Now switch to the Commands Tab and modify the text fields as shown in the following image.

    Commands Tab

  5. Explanation of previous step. You can run man shutter in terminal to see what are the different CAPTURE MODE OPTIONS available.

    • Screenshot command line: shutter -f - This captures the entire screen. Activated when you press Print.
    • Window screenshot command line: shutter -a - This captures the current active window. Activated when you press Alt + Print.

Enjoy taking screenshots with Shutter!!

  • 1
    Great, works like a charm! – TIIUNDER Feb 8 '13 at 14:39
  • Awseome answer! But why the "#¤&%& is this not easiert to do in Ubuntu. – Lennart Rolland Oct 14 '15 at 10:19
29

Ubuntu 14.04: for some reason neither "CompizConfig ⇒ Gnome Compatibility" nor "All Settings ⇒ Keyboard ⇒ Screenshots" worked for me. One thing that helped me was to define custom global shortcuts. I went to "All Settings ⇒ Keyboard ⇒ Screenshots" and removed all conflicting bindings on a "Print" key, which I was going to use.

enter image description here

Then in the same window I opened a "Custom Shortcuts" section and created two custom shortcuts for Shutter.

enter image description here

  • Full screen with Shutter – shutter -f
  • Take a screenshot of an area with Shutter – shutter -s
  • 5
    I tried to assign Alt+Print to take a screenshot of a window, but it's not letting me. Any ideas why? – Felipe Jan 13 '16 at 6:31
  • 2
    To get Alt-Print to work I had to edit the setting with dconf-editor in path /org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom?/ where ? is a number and set the binding to <Alt>Print – Jonah Graham Apr 5 '17 at 16:12
  • Confirmed for Ubuntu 16.10. – somethis Apr 11 '17 at 20:31
  • Only the custom shortcut work for me on Ubuntu Desktop 16 – Nam G VU Jun 27 '17 at 12:29
22

Without installing anything other than shutter, go into system settings, then keyboard, click the shortcuts tab, click custom shortcuts, then the + button to add for example, the following custom command :

. . name = shutter -f  
. . command = shutter -f -e -o 'Desktop/%name_%T.png'  

and click the apply button. Now click that new line in the list of custom commands and hit the print screen key. This will reassign the key to take a snapshot using shutter.

To see the shutter options, type man shutter into a terminal screen. My example takes a full screen screenshot and saves it to the desktop with no other user interaction needed.

Other useful options are to replace the -f with -a for the active window, and with -s for a selectable rectangular portion of the screen.

Having taken some screenshots you can use them directly from the desktop (or wherever you saved them to) or annotate them etc by opening the shutter program itself, in which they appear.

7

For Ubuntu 18.04:

  • Go to Settings -> Devices -> Keyboard
  • Find Save a screenshot to Pictures and disable the Print Keybinding (otherwise it doesn't let you reassign the Print Key.
  • Add a new Custom Shortcut at the bottom
  • Enter any name and the command shutter -s (For area selection)
  • Assign the Print Key.
  • Click Add at the top.
5

I am not using Ubuntu 15.10 Unity Distro. So the the Gnome Compatibility tool of compiz just didn't worked for me. So I used Michael's method (above). Go to All Settings -> Keyboard -> Screenshots.

pic1

Then at first disable the "Take a Screenshot", "Take a screenshot of a window" and "Take a screenshot of an area" options by clicking on the options and pressing backspace.

And then go to "Custom Shortcuts" option and click on the plus button to add a new shortcut. To create screenshot for the whole desktop write the command "shutter-f" and and to take a particular area screenshot write the command "shutter-s".

pic2

Now after creating two Custom Shortcuts you have to assign the key to these Custom Shortcuts. Click on the "Disabled" area and press the key that you want to assign to this function. I recommend to use "Print" Key for full screen captor and "Shift+Print" for an area to captor.

Close the window, and then you are good to go...


Similarly you can even use gnome-screenshot tool. Just use "gnome-screenshot" command for full screen shot and use "gnome-screenshot -a" command for using the tool for an area. You can also use"gnome-screenshot -w" command for capturing a specific window.

I actually use gnome-screenshot tool because I it is way more fast and light weight. But it has less feature.

  • worked like a charm. I am on Ubuntu 15.10 as well. Thank you! – BustedSanta Feb 23 '16 at 14:38
  • 1
    May I ask what design you are using? – Nearoo Aug 10 '16 at 12:51
  • I have used a simple program called 'pinta' @Nearoo. – Ryko Nov 22 '16 at 8:15
  • @Ryko I mean the style of your system... you know, the one that is "Ambience" by default – Nearoo Dec 3 '16 at 0:18
  • Oh I see. I am using "Arc darker" theme and "Breeze" as icons. @Nearoo – Ryko Dec 4 '16 at 8:18
0

Ubuntu 14.04 has a screenshot section now. Doesn't answer your question, but it's a simple alternative.

enter image description here

  • You still have to get that annoying popup every time – Menasheh Jan 2 '17 at 19:24
0

For ubuntu 17.10, all the above solutions did not work for me.

Even when I disabled the default mappings and added custom ones (as outlined in the second answer), it didn't work.

To make it work, I did this:

  1. start ccsm
  2. deselect Gnome compatibility
  3. Select Commands
  4. Add a command and a corresponding key binding e.g. shutter -f
0

To share 1/24/2019 since I also use this For Ubuntu 18.04.1

Go to settings - > Keyboard -> Screenshots * Change the default "Save a screenshot to pictures" with something else (other key combination)

Then go below to add a custom shortcut As of this writing Im using shutter. ;)

shutter command

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.