4

How to auto start network-manager?

I installed ubuntu mini iso and ubuntu-gnome-desktop (without the install recommendations). So, I have the system working fine, except that the network manager do not automatically start. I even tried adding it to the gnome-session-properties (startup applications), but no luck.

I am using the following command to manually start it through terminal: sudo service network-manager start

I also get the message while booting saying that 'waiting for netwrok configuration' and then 'booting without full network configuration'.

5

In my case, I had a left over entry for eth0 in /etc/network/interfaces which was configured to use DHCP, but since there was no ethernet plugged into eth0 DHCP could never succeed.

Check /etc/network/interfaces, comment out everything other than:

auto lo iface lo inet loopback

Then reboot and hopefully network-manager will start as expected.

1

1)In /etc/ there should be some rc files or an rc.d, search around in them and try to figure out which services (Daemons) are starting up on boot.

2)Try the following: I deleted all pid file in /var/run and all subfolders especially /var/run/dbus I moved all data from /var/run to /run then deleted /var/run folder. I made a symlink /run to /var/run.

3) Follow this article https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/811441 and look at #24. Although the version they are talking of is different from yours, the suggestion might help.

1

Maybe this workaround of mine could help you. Note that it doesn't solve the root cause of this situation, it just makes things simple and functional.

First, execute this command:

sudo vim /etc/rc.local

Then, the content should look similar to this:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

#Sleeping a little might be necessary to let it catch up the boot. 
#However, for me, this sleep was a useless overhead.
#sleep 3 
service network-manager restart

exit 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.