I'm trying to run Hiren's BootCD on QEMU but it throws a hardware error 0x80000021 on a Core 2 Duo, maybe there is some parameter missing to fix that.

$ kvm --version
QEMU emulator version 1.0 (qemu-kvm-1.0), Copyright (c) 2003-2008 Fabrice Bellard
$ uname -a
Linux tiago-pc 3.2.0-37-generic #58-Ubuntu SMP Thu Jan 24 15:28:10 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
$ lsb_release -r
Release:    12.04
$ cat /proc/cpuinfo
output file: http://pastebin.com/7afK8dZ6
$ kvm -m 512 -cdrom PATH_TO_THE_FILE/HBCD_15.2.iso -boot once=d
KVM: entry failed, hardware error 0x80000021

full output file

The boot list is shown, but doesn't matter which option I choose it always gives the same error, I've tried on qemu-system-i386 and qemu-system-x86_64 as well, resulting in the same problem.

I do upgrade and dist-upgrade every day, and I've just tried to run it on 12.10 livecd (of course, without upgrade), unless it was fixed after the release the problem still happens!

Some sites I found with this error says to add the parameter -cpu core2duo or -enable-kvm but it didn't solve the bug.

Screen: http://img15.imageshack.us/img15/2797/ss00.png
  • I fixed the problem, can I share the solution? Please, reopen the question! Feb 14 '13 at 11:07
  • I've tried to install 12.10 on a external drive and update till the kernel last version, but the problem persisted, I even installed the drivers from ppa:oibaf/graphics-drivers didn't work. So I used the external drive in an older computer, with Pentium 4, and it worked, so I came back to my computer and tried to disable some flags on bios, and I discovered when I disable the Vanderpool it works, but QEMU doesn't use the CPU virtualization, unfortunately I have to live without it, but at least works. Feb 14 '13 at 11:57
  • @TiagoPimenta - question has been reopened - please create an answer and you can also mark it as accepted as well to close the question. Thanks.
    – fossfreedom
    Feb 14 '13 at 15:19

It is a known (kernel) bug:



There is a fix released for Ubuntu 12.10 but that I know (from my google search) not 12.04.

There are also reports of this error being thrown when you allocate insufficient memory to your guest. Try allocating 1024 Mb.


  • 1
    If it's a kernel bug fixed in 12.10, then installing the kernel from 12.10 via the linux-generic-lts-quantal package will do the trick.
    – gertvdijk
    Feb 14 '13 at 15:35

I was able to fix the problem disabling on BIOS the flag Vanderpool, it seems Core 2 Duo don't have a full virtualization support, since the error says "the guest maybe running in big real mode which is not supported on less recent Intel processors", QEMU runs well on a Core i5 I have at home, and on a Pentium 4 without VT support!

Well, I hope QEMU could workaround these kind of problem in the future, but for now the problem is fixed.

  • You can also use -no-kvm option on qemu-system-i386 Feb 14 '13 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.