I'm trying to install Ubuntu 12.10 alongside Windows 7 on my ASUS laptop and I'm new to all of this.

I'm using the Ubuntu 12.10 64-bit ISO burned onto a CD.

The first time I tried to install it, Ubuntu said it did not detect any other OS, which meant I only had 4 options:

  • Erase disk and install Ubuntu (I don't want to do this)
  • Encrypt new Ubuntu.
  • Use LVM.
  • Something else.

If I choose the Something else option, it brings me to the partition menu and says that I have 1 disk with free space of 750516Mb (750Gb), but that's not true because I have Windows 7.

I've already read through several questions and people have mentioned that you could only have 4 primary partitions. So I got hold of partition magic and removed my D: and E:, leaving me with primary C: partition and System reserved partition and a lot of unallocated space.

I restarted the laptop several times and booted the CD again and I got exactly the same as I did previously.

How do fix this problem and install Ubuntu alongside Windows 7?


Here are my results for

sudo fdisk -l; echo; sudo parted -l; echo; mount; echo; df -h

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x90050371

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   146368214    73080683+   7  HPFS/NTFS/exFAT

Warning: /dev/sda contains GPT signatures, indicating that it has a GPT table.
However, it does not have a valid fake msdos partition table, as it should.
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT
partition tables.  Or perhaps you deleted the GPT table, and are now using an
msdos partition table.  Is this a GPT partition table?

After selecting YES

Yes/No? yes                                                               
Error: The backup GPT table is corrupt, but the primary appears OK, so that will
be used.
  • 1
    I must tell you that I found several questions and external treads of users with the same issue. It happened to me also, but my final choose was remove Win7. I think that its a bug but I can't confirm it. – Lucio Feb 7 '13 at 17:03
  • I could be wrong here but I think you need to have free space and not "unallocated space". – user25656 Feb 7 '13 at 17:03
  • 2
    @vasa1 Yeah, but thing is that Ubuntu doesn't recognize the partitions as it should do. – Lucio Feb 7 '13 at 17:04
  • Lucio- Well if I did try to install Ubunto onto the whole disk then that would be I lose my Win7. – NigelHoppus Feb 7 '13 at 17:06
  • @NigelHoppus In such case you will lose all the data of the C: partition. If you have important information there, you'll lose it. You can backup this data before install Ubuntu on an external drive and then restore it on the new OS. – Lucio Feb 7 '13 at 17:08

I had a similar issue and did the following:

  • made swap and Ubuntu root filesystem (ext4) partitions with acronis
  • left 1GB of free space (unallocated)

After this it saw my ext4 and swap partitions and I was able to install Ubuntu.

|improve this answer|||||
  • But were your Win7 C: drive and system reserved drive present before you made the swap and Ubuntu file system partitions. – NigelHoppus Feb 7 '13 at 18:03
  • @adi I don't think that this answer is appropriate. If you create a partition, you won't be sure if this will write over your windows partition. What OS do you had that wasn't recognized by Ubuntu? You're windows was working ok after that? – Lucio Feb 7 '13 at 22:32
  • I had windows 7 x64 installed with system reserved partition also and when i wanted to install ubuntu 12.04 LTS amd64 it only gave me the option to install on all HDD instead of showing me partitions.It was a whole process would take me a lot of lines to write so il keep short: if i had 4 partitions,C:Windows,System reserved,Linux Swap,Ext4 filesystem, no unallocated space, the problem persisted, when i left 1GB of unallocated space it showed me all partitions, including the unallocated space, don't know why.And yes windows 7 is working properly and ubuntu the same. – adi Feb 8 '13 at 9:31
  • Of course using acronis is at your own risk, if you dont know how to use it you may brake your windows 7 partition so look on the internet how to make partitions with acronis disk director if your not sure. – adi Feb 8 '13 at 9:45

I understand that you want to run both OS in the same laptop, not exactly having it in a separate partition or whatever other complex thing.

If that's what you want, the easy way to install ubuntu would be using Wubi. You can check it out here http://www.ubuntu.com/download/desktop/windows-installer

It will let you install it from Windows and makes all the questions you need to answer during the installation. If in the future you wanted to erase Ubuntu, you would be able to do so from the control panel in Windows.

I used it to install Ubuntu in my laptop and it has been running perfectly. I use a dell n4050 and it worked smoothly from first time without problems.

Hope this has helped you.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.