Note to others if you just want a summary of the problem skip down to summary. This first part is going to be slightly long and hopefully entertaining. As in, that is screwed up! but there might be a clue in there.

So I bought my laptop. From the very beginning, and occasionally for no known reason it's screen would freeze. The keyboard would freeze and the keyboard shortcuts on wikipediea, that try and shut down a frozen computer, were quickly found. The shortcuts didn't work either. It didn't happen often and got better with updates. Better means less frequently. Eventually it would happen only when under heavy load, when I was in Chromium with 10 tabs. Annoying but with no solution , I ignored it.

Well two days ago before work It did this, I shut the computer down as I always did,by holding down the power button. It popped back up and ran a hard drive check as it sometimes did and brought me to the login screen. Which is different then most times , usually it goes straight to the desktop. So I typed in my password and nothing happened, fine I called up a terminal trying to shut down the computer first by ctrl-alt-f2 as I always do. My computer not being frozen goes to command line, I log in and I type in one of the few commands I now know by heart sudo reboot! And it does in ten seconds, SSDs rock. And comes to the login screen.

Vague recognition occurs that this isn't Kansas anymore Toto, and Crap I haven't backed up in a while. No don't groan, I swear I'll back up more often, I swear I will learn what rsync does and create a keyboard short cut to back up my home folder. I'll go through rehab I swear just help me get my wallpapers and documents back please!

I broke X and I don't even know what X is, Its a video thingy mag jig, that puppy linux (dell mini sometimes) asks me X versa or X org. So I broke out my netbook a dell mini 9 that I bought with a tax return, I now have internet with a small screen, to small to enjoy really, 12 inch minimum is recommended , maybe 10 with a tablet. I come the interwebs for a solution and nothing. My google fu has failed me.

I think, well lets upgrade to 12.10, that should keep my files and fix the problem. Well It starts and I go to work. And doesn't work. I am now ubuntu 12.10 and no GUI. I try to reinstall the gnome shell via a command on the internet choose lightdm and nothing. I have tried these commands (not necessarily in order) sudo apt-get system76-driver , sudo dpkg –configure -a , sudo apt-get gnome-shell , sudo apt-get autoremove , sudo apt-get update, sudo start lightdm , sudo stop lightdm , do release-upgrade , sudo stopx , sudo killx , sudo startx, and sudo lsusb (that last didn't help me at all, note a lot of the responses went over my head)

So being terminaly board, get it I am in the terminal and board, and being as I have to go to work in an hour and being ready to work I type in the commands to run Diablo 3 I run my Ptrace command

echo 0| sudo tee /proc/sys/kernel/yama/ptrace_scope

*force_s3tc_enable=true setarch i386 -3 -L -B -R /opt/cxoffice/bin/wine –bottle “Diablo III” --cx-app “Diablo III laucher.exe”

and I am sure you are just shocked shocked to hear that I didn't run. It can't create a window, can't find a driver or some such. And if your thinking thats an lot of flags and command line fu for someone who doesn't speak the language , your right, you would be surprised to find out what a monkey with an Internet connection , the ability to copy, with out really understanding whats going on, can do. Yes I am not an idiot, yes I am learning, but no I really dont know what I am doing. Downloaded a book to kindle today on the ubuntu command line. What I want from the readership here

  • A brilliant concise solution thats easy to implement to just fix X.

  • or A solution to fix my X

  • and/or someone tell me how to find my pictures folder path, documents folder path, and my usb path (it still auto mounts apparently) so I can use the copy command I found and copy to my stuff to usb and in my second hardrive mounted in my computer I have file I need /unknownpathtoharddrive/OSs/ubuntu12.1064bit.iso I would like to get that to my USB.


System Spec Ubuntu 12.10 64 bit 15.6" 1080p Full High Definition LED Backlit Display featuring 95% NTSC Color Gamut in Matte Finished Surface ( 1920 x 1080 ) Intel HD Graphics 4000 3rd Generation Intel Core i7-3610QM Processor ( 2.30GHz 6MB L3 Cache - 4 Cores plus Hyperthreading ) 8 GB Dual Channel DDR3 SDRAM at 1600MHz - 2 X 4GB 120 GB Intel 520 Series SATA III 6 Gb/s Solid State Disk Drive 750 GB 7200 RPM HDD + Caddy Case Intel Centrino Advanced-N 6235 - 802.11A/B/G/N Wireless LAN + Bluetooth Combo Module

  • GUI Borked , doesn't work kewbluie, Snafu, oh Snap.... you get the idea infinite login loop
  • wrong password produces “incorrect password” correct password produces a bell and goes back to login page (or never leaves?)
  • good news- ctrl-alt-f2 works and gives me a command line. And I can log in!
  • problem-I don't speak command line. Vim? haha your kidding right
  • Problem- I don't know the commands so it can report the problem so I cant google the answer


  1. vague goal of reinstalling without losing a couple of word documents and wallpapers
  2. I have tried: stop and start x, stop and start lightdm , installing updates, Ubuntu upgrade, and running Dablo and Natulius Update: Just tried to log in under guest, full GUI interface, now I am flumuixed , so its some setting that doesn't allow me to log in with a gui on my main account, but I can with the comand line,as soon I get my info fresh install.
  • We want to help, we don't need entertainment here - please edit your question to keep only the relevant parts. – guntbert Feb 6 '13 at 22:07

Log in from the command line and do an ls -A to see all your files. Shift + page up/down scrolls. You probably have a borked X session. Delete everything related to X. The names will begin with .x or .X. Try to log in normally.

If that doesn't work, look at the file .xsession-errors and post anything interesting from that file. You can use the less command to look at files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.