I have a new HP Envy dv6-7315tx laptop. I installed Ubuntu 12.10 (64 bit), which went smoothly after switching the BIOS to legacy mode, and it has completely replaced Windows 8. However, there are no proprietary drivers listed in jockey at all, and the WiFi/bluetooth card doesn't work. Ubuntu also fails to recognise the fingerprint reader and graphics card.


Card: Ralink RT3290 PCIe

Drivers: Ralink/MediaTek (linux) or HP (windows)

I'm aware of this similar question but there was no solution and I've tried some different things:

$ lspci (relevant part only):

0a:00.0 Network controller: Ralink corp. Device 3290
0a:00.1 Bluetooth: Ralink corp. Device 3298

$ lspci -m (ditto):

0a:00.0 0280: 1814:3290
0a:00.1 0d11: 1814:3298

I installed ndiswrapper and downloaded the HP driver linked above. The card doesn't appear to be listed on the ndiswrapper list so I just went with the HP one. It installed fine and ndiswrapper -l showed the correct Chipset ID. I followed the next steps in the Ubuntu Wifi guide:

sudo depmod -a
sudo modprobe ndiswrapper

then attempted to find the wlan interface, but no luck:

$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000

$ iwconfig 
eth0      no wireless extensions.
lo        no wireless extensions.

Next I tried to install the MediaTek linux driver for the card by downloading the tarball from the above-linked site and compiling it. Still no luck, even after a reboot.


$ rfkill list
0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

That's used up the extent of my experience with these things and I'm stuck with LAN for the time being. What else can I try?

[Edit: I had another shot at installing the Ralink/MediaTek driver and now I have a new network interface:

$ lsmod | grep rt3
rt3290sta            1174375  1
$ iwconfig 
usb0      no wireless extensions.
ra0       Ralink STA  
eth0      no wireless extensions.
lo        no wireless extensions.
$ sudo ifconfig ra0 up
$ iwconfig 
usb0      no wireless extensions.
ra0       Ralink STA  ESSID:""  Nickname:"RT3290STA"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated   
          Bit Rate:1 Mb/s   
          RTS thr:off   Fragment thr:off
          Link Quality=10/100  Signal level:0 dBm  Noise level:0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
eth0      no wireless extensions.
lo        no wireless extensions.

The problem is that I now get bluetooth and wifi both showing as hard blocked in rfkill and the new wireless section of the network manager indicator has the "wireless is disabled by a hardware switch" message. The only hardware switch is the f12 button which has always has a red light (wireless radio disabled) under ubuntu even though rfkill previously showed it as unblocked and rfkill event doesn't react to pressing the button. I made no BIOS changes since posting this question and there is still no Windows OS installed on the hard drive.

I'm also not sure about how to automatically handle the ifconfig step above. ]


Card: NVIDIA GeForce GT 635M

Edit: Working fine with bumblebee.

Fingerprint reader

Device: Validity ??? (ID 138a:0018)

Edit: Found a bug report for FPrint tracking support for this device. Marked as Fix Released but no version of that library I found in PPAs detected the device.

up vote 0 down vote accepted

I later discovered this bug report. Following the suggestions there, I enabled the network card in the BIOS then was able to toggle the hardware switch while the hp_wmi module was disabled. This allowed me to connect to my wireless router, but attempting to use the connection causes a kernel panic as with the bug reported linked here.

Pending the resolution of that bug, I'm using the suggested workaround. Specifically:

mkdir linux-mainline && cd linux-mainline
curl -O http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6.11-raring/linux-headers-3.6.11-030611-generic_3.6.11-030611.201212171335_amd64.deb \
     -O http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6.11-raring/linux-headers-3.6.11-030611_3.6.11-030611.201212171335_all.deb \
     -O http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6.11-raring/linux-image-3.6.11-030611-generic_3.6.11-030611.201212171335_amd64.deb \
     -O http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6.11-raring/linux-image-extra-3.6.11-030611-generic_3.6.11-030611.201212171335_amd64.deb
sudo dpkg -i *.deb
git clone git://git.kernel.org/pub/scm/linux/kernel/git/dwmw2/linux-firmware.git
sudo cp linux-firmware/rt3290.bin /lib/firmware
echo rt2800pci | sudo tee -a /etc/modules
sudo reboot

I got wireless working well under debian wheezy, but no bluetooth.


  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Eliah Kagan Feb 14 '13 at 22:52
  • Yes, the workaround I found also suffers from a lack of bluetooth but the wifi is working fine – arcresu Feb 15 '13 at 4:40

I found this post http://ubuntuforums.org/showthread.php?t=2115570

It has this link to drivers for the bluetooth part of the device.


The driver is provided from manufacturer Zotac, who uses the card in one of their machines. Although it has a gpl'd kernel module (which I was unable to build on debian wheezy), it seems to require running a binary from your startup scripts (more than the usual firmware blob).

I have an HP Envy dv6-7375ez laptop running dual boot Windows 8 and Ubuntu 12.04.03. The laptop comes with a Ralink 3290 wireless card. In Windows, it works fine. Airplane mode is switched on and off with the F12 key.

To get wireless to work at all in Linux, I had to upgrade the kernel to 3.6.11-030611-generic. Some people reported having problems getting this driver to work in 12.10, but I wanted to stay with 12.04 LTS anyway, so I upgraded the kernel. Details are here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1049466/ (see comment #16).

You can then follow the instructions in this link to download, build and install the driver: Wireless driver - how to load manufacturer's STA file (Ralink 3290). I was able to get wireles to work if no ethernet (wired) connection was present. However, Bluetooth and wireless WLAN seemed always either both enabled or both disabled. Turning one off or on would do the same to the other. Sinde I really don't care about Bluetooth and would rather have it off all the time, this was less than satisfactory.

After that, I updated the BIOS in a Windows Update session, and then I was always getting the "Wireless network disabled by hardware switch" even though I had run "sudo rfkill unblock all". Blacklisting the HP driver finally did the trick (see what it is called by doing "sudo lsmod | grep hp" ... on my system it is "hp_wmi").

I can now even turn wireles on or off using the F12 key. However, the indicator light is always the same, and after you hit F12 it takes a few seconds to toggle (i.e. enable/disable) the wireless, so check the network menu in the status bar to see what it is at the moment. I can live with this for now.

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.