In attempting to shrink my NTFS drive to a smaller size, so I can dual boot my currnet Windows 7 with a brand new Ubuntu 12.10 (didn't want to use Wubi), I've somehow managed to stuff up the drive and what Windows can see.

Essentially, after shrinking it with a partition manager, Windows blue screens upon restarting. I shrank it while Windows was running (which is valid to my surprise, according to many Windows 7 & 8 dual boot HOW-TOs), and it said to restart to finish off the process.

Other partition managers I burnt to an ISO say it's a raw format. Ubuntu *trumpets blare* to the rescue; the live CD said I can see your NTFS partition sure no problem.

SO. Here's my issue. I'd like to recover my drive, so that Windows can boot again. Whether I then format or not, I'd like to get Windows running so I can do things like run steam and properly back-up... run other programs that can't just be copied over.

How do I fix my NTFS partition from an Ubuntu Live CD?

I've tried so far:

  • ntfsfix /mount/point/31415: Runs & exits fine; have tried with all parameters
  • ntfs-label /mount/point/34154 NEW_LABEL: Said sure no problem. Hasn't helped.
  • fsck /mount/point/3115: Said it can't find/run fsck.ntfs. I can't find that package either.
  • Windows Recovery Tools: Not only does the Windows 7 installation disk (recovery tools) not pick up that there is a Windows installation on the drive, it thinks its a raw format and can't read it. Consequently, chkdsk doesn't work, as it can't see there's contents.

Help would be greatly appreciated!! :) I'll update this description with clarifications as they come.


  • Windows doesn't boot, but does attempt to: I get the Windows 7 logo, and the orb things start to spirl, but then it blue screens. The message appears too fast for me to read.
  • I haven't installed Ubuntu. I'm running it from the LiveCD.
  • Safe Mode: Blue screens during start-up. (see image above)

enter image description here

  • If it's too fast to read, get a camera and catch it in-action. ;)
    – user98085
    Feb 6, 2013 at 2:42
  • Lol; worth a try but might be too fast still :P
    – Michael
    Feb 6, 2013 at 3:14
  • @TehHippo Record a video then and freeze the frame. :)
    – Vreality
    Feb 6, 2013 at 4:05
  • @Vreality; will try. :P At work currently will try later. anyone else have type-this-and-its-an-instafix! solutions? :P
    – Michael
    Feb 6, 2013 at 4:14
  • have you tried ntfsfix /dev/sdaX - have to figure out the proper partition number (sdXY) and don't mount it. This will mark NTFS partition as dirty and Windows will scan it on next boot.
    – jet
    Feb 6, 2013 at 15:03

2 Answers 2


So! I gave up on the whole thing and after buying a new external drive and backup the data, went to install Windows again fresh (still need to dual boot). Windows STILL couldn't pick up the drive. That's when I got suspicious.

  1. I went into gparted
  2. Deleted the mount that I'd attempted to create in Windows
  3. RE sized the drive back to what it was before.
  4. Rebooted.
  5. Windows asked whether I wanted to recover Windows (instead of booting normally)
  6. THIS TIME, it actually seemed to do something.
  7. Rebooted, and all was well.

Thanks to the advice from all. Turns out even undo'ing what you've done with partitions can sometimes fix issues.


Try reverting back to a recent version of Windows or restoring from a backup. If neither work or you don't have either one, you can always go with re-installing Windows after backing up the data you want from the hard drive. If you need an install iso, they're (legally) online. Depending on your product key, you can use one of these links:

You can also copy the files over from the disc (including hidden ones) then put them on a new partition and see if Windows will boot from that. You can use QEMU's kvm command to try booting from a drive. Example:

kvm /dev/sda

With the kvm command, you don't list the partition with the drive; it's also best to have the drive unmounted although it may not matter.

  • Thanks and I appreciate the response, but that's not what I'm after and is quite generic anyway. If I had a previous version of Windows I certainly would have tried that! :) Wish I did.
    – Michael
    Feb 6, 2013 at 4:57
  • @TehHippo I agree, it's generic, but I'm not competent enough to tell you otherwise. :( Doesn't Windows automatically create system restore points? (That's what I was referring to by previous version of Windows.)
    – Vreality
    Feb 6, 2013 at 5:01
  • It's not able to read anything on that drive, so anything that Windows created for backup/restore purposes, it's not able to access. :(
    – Michael
    Feb 6, 2013 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.