24

i have been trying to configure transmission-daemon so i can connect using the webui avaliable at http://server.ip-address:9091 , but i just get a message telling me that i should either disable the ip address whitelist or add my current ip to it.

I edited the file avaliable at /etc/transmission-daemon/settings.json and modify the rpc-whitelist-enabled parameter to false, save the file and restart the service with: sudo service transmission-daemon restart. After that i double-check the settings.json i just modified just to discover that all my changes have been undone. What is goin on here?, any one else have seen this behaviour before?

3
  • 1
    Okay... just discovered what was going on, if you edit the settings.json file you must restart the service with: sudo invoke-rc.d transmission-daemon reload
    – AcidRod75
    Commented Feb 5, 2013 at 23:28
  • 4
    Transmission daemon rewirtes the config file on exit. To edit it without overwrite you have to sudo service transmission-daemon stop before editing.
    – con-f-use
    Commented Feb 5, 2013 at 23:30
  • @con-f-use Please put your comment as an answer. It deserves to be accepted as the correct response.
    – Zoot
    Commented Oct 9, 2013 at 21:02

2 Answers 2

33

Transmission daemon re-writes the configuration file with the old options when it exits. To make your changes persist, you need to edit the configuration file without the deamon running. So first:

sudo stop transmission-daemon

Or if you did not install it via Software Center / Official repositories:

sudo killall -HUP transmission-da

Afterwards you can edit settings.json as you would expect and then restart transmission:

sudo start transmission-daemon 
1
2

Edit /var/lib/transmission-daemon/.config/transmission-daemon/settings.json which seems to be file which is copied after every restart of the systemd unit transmission-daemon.service. I didn't find a reference, but a simple test confirms.

1
  • editing both didn't resolve my issue. even when the service had been stopped. Commented Sep 17, 2019 at 13:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .