I got a Dell xps 8500 pre-installed window 8. I installed ubuntu 12.10 and after reboot the system directly enter into ubuntu. I use boot-repair and I got the grub menu with ubuntu and windows 8. If I enter Ubuntu, there is no problem. But if I enter Windows 8 it is ok for the first time, but if I restart the system, I got a line "No bootable device available!!! Press any key to retry." on the top of the screen.

In the bios I open the UEFI and secure boot.

This is the boot info: http://paste.ubuntu.com/1611189/.

What can I do now?

2013-02-07 Thanks Rod Smith very much for his great help. I summarize here my problem and the solution:

  1. Platform: Dell xps 8500, 1T hdd, pre-installed Windows 8; UEFI open, secure boot open
  2. Problem: Install Ubuntu 12.10 (I want to use 10.04, but because only from 12.10 UEFI and secure boot is supported), everything is ok except entering Windows 8 and restart. The system will not find boot device. The reason here is a 'windows boot manager' that revise the boot file.
  3. Solution: in Command Shell type: "bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi" to correct the bootfile. The "shimx64.efi" file is under "/boot/efi/EFI/ubuntu/". (As Rod said we should choose shimx64.efi since I open secure boot option; this also can be found after using 'boot-repair' which says: "Please do not forget to make your BIOS boot on sda1/EFI/ubuntu/shimx64.efi file!"; so if your system is different check there.)
  4. Note: as before the solution I have tried with Rod's advice to kill "fast boot" and "hybrid boot" options. I didn't test if I change back to "fast boot" will have problem. Anyway, this can be tested since now the system works fine.
  • I tried "powercfg -h off" under Windows 8 doesn't help. I power off with the button under Window 8, and then power on the system, ubuntu is gone.
    – wt70707
    Feb 6, 2013 at 7:38
  • I think windows 8 change the uefi when it starts. I check my BIOS, when there is a boot option as "UEFI:ubuntu", then ubuntu can be started. And when the option is "UEFI:windows boot manager", then Windows can be started once, i.e., after reboot from that the "no bootable device" will emerge.
    – wt70707
    Feb 6, 2013 at 7:46

1 Answer 1


This is a bit of a shot in the dark, but my suspicion is that you're running into problems because of a Windows feature called "fast boot" or "hybrid boot." This system basically involves a suspend-to-disk rather than a shutdown. This is known to cause problems on dual-boot systems, and IIRC, it can even corrupt the EFI System Partition (ESP), which can lead to the symptoms you report. A quick Google turned up some sites with instructions on shutting off this feature:



Note that I don't have a Windows 8 installation, so I can't offer any firsthand advice about this; I'm just passing on what I've read elsewhere.

Edit: If Windows is "taking over" the boot process, you can fix the problem by using the Windows bcdedit command:

  1. Boot Windows.
  2. Launch a Command Shell prompt with Administrator privileges. (You do this by right-clicking the shell icon and selecting the option to "Run as Administrator.")
  3. Type bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi to register GRUB as the desired default boot program. (Note, however, that if you haven't disabled Secure Boot, you may need to specify shim.efi instead of grubx64.efi. If you're using something other than GRUB, or if it's not in the specified location, you'll need to adjust the command appropriately.) Note that {bootmgr} should be typed exactly that way, including the curly braces; that's not an attempt to denote a variable.

Thereafter, Windows should settle down and stop disabling GRUB as the default boot program.

  • Thank you for your help. I check off all the fast boot things. Still the same. This time I tried firstly shutdown (not restart), then I get back to windows (Ubuntu disappeared). Then I restart, the same things. I googled with "windows 8 restart", and do "bcdedit /set disabledynamictick yes", no help.
    – wt70707
    Feb 7, 2013 at 4:50
  • Someone said about the bios. Anyway my pc has just arrived no more than one month. Still I checked Dell for xps8500, it is A09 (12092012), while my pc is A09 (09052012). And in the CMOS, the boot device will change between (UEFI:ubuntu) and (UEFI:windows boot manager). I suspect when I enter windows 8, windows boot manager does something to change the EFI files.
    – wt70707
    Feb 7, 2013 at 6:13
  • Please see my edit/additional information.
    – Rod Smith
    Feb 7, 2013 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.