The fan on my dell inspiron 7520 (inspiron 15R SE) is constantly running at full speed with a lot of noise.

technical details:

  • GRAPHICS : 2GB AMD RADEON HD 7730M, switchable/hybrid with intel 4000 graphics
  • INTEL CORE I5-3210M 2.50
  • 6GB RAM
  • 1080hd display
  • 750gb harddrive
  • dual boot win7 64 and ubuntu 12.10 64
  • bios version A09 (1. jan 2013 =newest)

i tried out a lot of suggestions from searching thousands of forums, they all didn´t help out, fan keeps spinning. here´s a list of the things i did, maybe i can help someone to avoid the work or somebody has a solution i haven't tried yet:

the useless options

  1. trying different OS: in windows 8 and 7 everything works fine. ubuntu 12.04, 12.10, 13.04 in each case 32bit and 64bit i have noisy fan

  2. bios options/update: i updated bios from A07 to A09, no change in fanspeed intel speedstep, intel smart response, ahci, ata mode, no changes in fanspeed

  3. using different partition tables, boot modes: i used uefi boot on a gpt partition, on mbr and legacy boot, no changes in fanspeed

  4. switcheroo: the only thing of little help is the switcheroo options from this link https://help.ubuntu.com/community/HybridGraphics switching off the AMD card actually only saves power but doesn't reduce the fan speed

    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
  5. power option: this link Dell Inspiron7520 and Ubuntu 12.04 issues was so far the most helpful comment, it reduces fan speed imediately, but with little cpu usage rises up to full speed again...so not a satisfying solution.

    echo "min_power" | sudo tee /sys/class/scsi_host/host*/link_power_management_policy

    taking out the ac plug reduces fan speed in most cases as well, but runs at full speed from time to time.

  6. graphics drivers: the catalyst drivers didn´t work at all. i tried different once from 12.something up to 13.2 beta after installation unity or compiz didn´t work and i had a blank desktop screen, besides fan speed wouldn´t change.

  7. kernels: i tried several kernels up to the new quantal 3.7, nothing changed

  8. i8kutils/lm sensors, pwmconfig: to control the fan manually lm sensors with pwmcontrol didn´t work( no compatible sensors detect...something like this) i8kutils from this thread http://forum.ubuntuusers.de/topic/dell-inspiron-15-se-7520-luefter-dreht-auf-vol/#post-4743072 controled the fans and kept the noise lower but the temparature rises and fan starts spinning a few seconds and stops, starts again and stops and so on, that is even more disturbing than running at full speed...so, no option for me.

  9. jupiter: jupiter saves battery power but doesn´t reduce fanspeed.

and here comes the most questionable thing. my flatmate has the exact same model.the difference is she has bios version A02 (or A04 not sure now), with a 1tb harddrive and no 1080 hd display and ubuntu 12.04 dual boot win 7 each 32bit works just fine out of the box. i tried to downgrade bios to A04 but doesn´t work, an error occurs.

i find myself working on this far too long, i am behind this since months. i even try to make myself comfortable in windows, although i never want to go back to thas os.

greetings zanza

i ran lm-sensors and i dont really know how to interpretate the output message. on the other laptop mentioned above, same model with little differences it shows next to temp1 also temp2

my lm-sensors shows this:

Adapter: ISA adapter
Physical id 0:  +43.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +43.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +41.0°C  (high = +87.0°C, crit = +105.0°C)

Adapter: PCI adapter
temp1:        +48.0°C  

lm-sensors of the other laptop (same model, with differences like mentioned above) shows this:

Adapter: Virtual device
temp1:        +27.8°C  (crit = +106.0°C)
temp2:        +29.8°C  (crit = +106.0°C)

Adapter: ISA adapter
Physical id 0:  +50.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +50.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +51.0°C  (high = +87.0°C, crit = +105.0°C)

can anybody explian me what it means?

  • I think this will solve the issue - askubuntu.com/questions/205112/… . Unless you install the drivers correctly, both GPU is on and to cool down them fan must run. – Web-E Feb 5 '13 at 19:05
  • Have you looked at this answer askubuntu.com/a/232125/32548 – Chris Carter Feb 5 '13 at 19:05
  • the i8kmon fancontrol from this page askubuntu.com/a/232125/32548 is no solution since it doesnt solve the real problem and has side effects like described above. the driver installation for the intel 4000 driver seems to be interessting, although the description from this page askubuntu.com/questions/205112/… doesnt work for me, maybe because thez test it with a intel 3000. ubuntu stops booting with message: "low graphics..." – zanza Feb 6 '13 at 15:32
  • another question.does ubuntu support the intel hd4000 graphics card? because when i switch off the amd 7730m discrete graphics card, the fans are still spinning. – zanza Feb 7 '13 at 11:43
  • @zanza, did you got any solution, I'm in the same problem?? – Noor Mar 3 '13 at 1:35

So, I had the same problem with my Inspiron here, however, I've got an Nvidia 630m and Intel GPU's. To solve it, I'm using bumblebee since he manages my needs of performances, and with that, doesn't overheats my notebook. I don't know if there is such software for AMD, but you should look for that, since the fan works nonstop for this reason.

|improve this answer|||||

have you looked at this post here? http://asusm51ta-with-linux.blogspot.com.br/

(4) OPTIONAL: Script to turn off laptop

This next script is used to turn off the computer. Because, in my case, if I turn off the computer without switching on both cards (specially when the integrated card is on and the discrete card is off), the fan runs at full speed when I turn it on again, stoping only after rebooting. Hence, to avoid this, this other launcher can be used to turn off the computer:

|improve this answer|||||
  • thanks for your answer. i read about this problem, but switching on the card before shutdown didn solve it. i doubt that the fan spinning has something to do with the graphics. i got the fglrx driver running on 12.04 and i still had the problem with the fan. even when i switch off the am 7730 card. i rather think it must have something to do with the motherboard or the chipset drivers. i went back to i8kfan although this is not a solution at all, it just makes it slightly more comfortable handling the problem – zanza Feb 12 '13 at 10:10

I had the same issue, and after dwelling for whole day, my fan stopped making noise. This have to do with using GPU. I tried few suggestion from askubuntu, but the one worked for me was from AMD website.

Go to http://support.amd.com/us/gpudownload/Pages/index.aspx and from the list, select the Graphic card you have in your pc. Download it and make the file executable and run it via Terminal. Something graphical installer will pop-up, select what best suits you (I did not select custom), and after finishing installation, just reboot your pc.

I don't have the fan noise now, and my Graphics are working perfectly. I also have AMD Catalyst Manager to play with...

|improve this answer|||||
  • 1
    i did this, but still same issue, I have ATI Radeon HD 7730, any help?? – Noor Mar 3 '13 at 1:39
  • 1
    can you open the ati-catalyst GUI controller now ? If you can you can set the graphics card (which one to use, either AMD ot Intel) from there and reboot. I certainly worked for me, I don't have any noise from my fan. – user126851 Mar 3 '13 at 19:36
  • Thanks for the reply, I'll definitely do it again, I currently using i8kfan turning on one fan for the time being, I'll see to it soon – Noor Mar 4 '13 at 1:21
  • Would someone confirm if this solution worked ? I tried this on Linux Mint and it screwed up the whole system ! Will this work right away on Ubuntu 13.10 ? – Muhammad Gelbana Nov 15 '13 at 22:53

I have a pretty similar model.

I have the catalyst driver installed (HD 7700 Radeon). VGAswitcheroo does not work for me AT ALL - it hangs the machine. Many different revisions of the catalyst driver and BIOS. (I'm at A09 now). I don't think that there is a way to roll-back the BIOS, but I recall that some earlier models have a set of contacts on the motherboard that you can ground and that clears the bios back to the original state. But this was desktop machines, and over a decade ago.

My fan seems to spin up when it needs to - but wont spin-down when it's not needed.

I have the same problem with speed-step. (seems to default to 2.10 GHz on wake-from-sleep, requiring manual reconfiguration every time).

Also, every time I reboot, I have to turn-off Bluetooth. That setting won't persist.

What I do for my fan, is I use "sudo i8kfan 0 0" (from i8kutils) in a terminal, to spin-down the fan. But I must use the Hardware Sensors Indicator and PSensor to tell me whether it ever overheats, (because sometimes the fan won't spin back up; if ambient room temperature is hot, and CPU load goes up). I use CPU Scaling Frequency Indicator to ramp down the clock to 1.2 GHz (which is fine for almost all purposes), and this generally keeps the temperature down low so that I can run the fan at 0 or 1 (depending on the air temperature).

I also have a conky setup that keeps track of the CPU frequency, and heat, and fan-speed relationship. So that I always have a visual cue. (It's not a problem that I need to monitor manually, if I just leave the fans alone at 2, which is full-speed, but then it's loud).

I'd really like it if there was a tool that could automatically and dynamically balance these factors. And especially, the fan-speed override - without having to use a command-line where I have to authenticate.

|improve this answer|||||
  • It would be better to put this in as a comment. However you could help by showing how you install and use software such as i8kutils so that they can install it themselves and use it. – andybleaden Jun 14 '13 at 7:31

I have the same model but with a higher spec. I don't use Ubuntu but I had the same fan speed problem. When I searched on the web for solutions I found this one as well as some others. I hope the following are helpful.

echo "min_power" | sudo tee /sys/class/scsi_host/host*/link_power_management_policy

This helps a little. But did you try to run this command?

pm-powersave true

This script not only sets min_power, but a lot of other power related tweakings.

Another approach you can try is to create a file /etc/modprobe.d/i915-kms.conf and put the following line in the file. I got this from here.

options i915 modeset=1 i915_enable_rc6=1 i915_enable_fbc=1 lvds_downclock=1 semaphores=1

Depending on the kernel version you use the acceptable i915_enable_rc6 value is different. The patch here describes the difference. You can run modinfo i915 | fgrep i915_enable_rc6 to see if a value higher than 1 is acceptable.

|improve this answer|||||

Check the discussion on this bug I opened recently. It has many great advices and links for dell inspiron machines. https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1272781

|improve this answer|||||

Didn't saw you mentioned using Intel(R) Graphics Installer for Linux. I had some fan issues myself. The problem seems to be the conflict between CPU and GPU graphics. Intel graphic installer solved it.

Unfortunately it doesn't support Ubuntu 14.10 at the present time, so I managed to resolved it by using Nvidia X Server settings and selecting CPU graphics as desired.

|improve this answer|||||

I finally found a solution. I have deactivated "Integrated NIC" in bios. It prevents my fan from becoming noisy. I am currently running Ubuntu 15.04.


|improve this answer|||||

Try this


and then select fan speed and change as you want ;)

|improve this answer|||||
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Oyibo May 26 '13 at 9:18
  • This answer is not self contained and no edit could ever hope to salvage it. – Braiam Sep 28 '13 at 19:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.