So I recently installed Ubuntu 10.10 64-bit on my computer.

I installed it on my 60gb SSD hard drive, and in the installation it never acknowledged the existence of my second hard drive.

The hard drive that I keep all my files on, and which I want to make my home folder if I can, is a Western Digital Caviar Black 1TB SATA 6Gb/s 64MB cache (WD1002FAEX).

I've read the following: https://help.ubuntu.com/community/Mount but honestly cannot work out how to access the hard drive from my Ubuntu installation.

I did have Windows 7 64-bit prior to installing Ubuntu. I have backed up all the files on the hard drive, but if I could just access them straight off that would be super cool.

The following directories are currently in my /dev/ folder:

ati/, block/, bsg/, bus/, char/, cpu/, isk/, input/, mapper/, net/, pktcdvd/, pts/, shm/, snd/, and usb/

Result from sudo fdisk -l

Disk /dev/sda: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d2dfd

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        6994    56174592   83  Linux
/dev/sda2            6994        7298     2438145    5  Extended
/dev/sda5            6994        7298     2438144   82  Linux swap / Solaris

Does anyone know how I can use the second hard drive?

@djeykib So very close to fixing it.. unfortunately on the last command you gave it says this:

$ sudo apt-get install linux-lts-backport-natty
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-lts-backport-natty

Checking on http://www.ubuntuupdates.org/ppas reveals that it is only available for 10.04. Looks like I'll have to unplug and re-plug hardware if I want it working still :(

  • 1
    Just to know, did you install gparted and see if it showed you the hdd?. Also did you verify that the hdd is connected (maybe a loose cable..just guessing here) – Luis Alvarado Feb 7 '11 at 16:15
  • I haven't installed gparted. I shall do that. – Jon Cox Feb 7 '11 at 16:27
  • @CYREX gparted does not show me the hdd, only the 60gb one. Do I need to reformat it or something? How would I do that? – Jon Cox Feb 7 '11 at 16:32
  • Can you also add the outputs from sudo lshw -c storage and lspci? Looks like the controller isn't recognised properly for some reason. – Oli Feb 7 '11 at 16:37
  • can you give us output of: cat /proc/partitions – jet Feb 7 '11 at 17:39

I read your ubuntu forum thread. Since the problem is the kernel, why don't you just update it? I'm thinking you should be able to just download the latest kernel, import your current configuration, and compile it after adding SATA 6.0 gB/s support.

I see a second option too, and more in line with the Ubuntu way: PPA. Check out UbuntuUpdates.org, they have a ppa that backports the Narwhale kernels to Lucid. I don't see why that shouldn't also work for Maverick. Go read their site first, and make sure this is something you really want to do, because it's definitely not supported; but it looks as easy as:

sudo add-apt-repository ppa:kernel-ppa/ppa
sudo apt-get update
sudo synaptic

Once you've got Synaptic open, you need to edit the repository so that you're accessing what is intended for Lucid.

  1. Click to Settings > Repositories
  2. Go to the Other Software tab.
  3. You'll see this line somewhere, probably at the bottom: http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu lucid main. Click to highlight it, then click Edit.
  4. In the box that pops up, make sure the Distribution field says lucid, not maverick. Synaptic: editing kernel-ppa repository
  5. Press okay, then press close.
  6. Press the Reload button in the menu bar.
  7. On the left side half way down, there are several buttons (Sections, Status, Origin..). Click the Origin button.
  8. Click the LP-PPA-kernel-ppa/lucid above that, and you should see all the new kernels you have access to.

synaptic screenshot of kernel-ppa

I trust you can take it from here?

For posterity, here is the bug fix report with all the juicy info. In short, support for your controller isn't around till Linux Kernel 2.6.37-rc4, aka Ubuntu Kernel 2.6.37-8.x.

To test this answer without buggering about your case and controllers and cables, please update your question with the output of lspci before, and after. You should see the controller going from Unknown to whatever it actually is.

  • Nah, that's a bunch of crap about it being only for 10.04. May be their intent, but that's a matter of hacking. See if you can find the deb and dkpg -i insert-package-name.deb it. Four eyes better than two. – djeikyb Feb 8 '11 at 13:21
  • Okay, think I've got it. Simple hack if I'm right. You need to edit /etc/apt/sources.list. Find the new entry for kernels, replace lucid with maverick. – djeikyb Feb 8 '11 at 13:47
  • Hrm. Y'know, it could just be I'm an idiot and gave you the wrong apt install command. Fire up synaptic and filter your search by Origin > LP-PPA-kernel-ppa/lucid. Should see some lovely kernel packages just waiting to be brought home to live with a caring sysadmin. apt-cache search --names-only "natty" bolsters this theory. Edited answer for accuracy. – djeikyb Feb 8 '11 at 14:39
  • I tried all of that but it still couldn't find it. So I gave up and just plugged it in a 3Gb/s port, will find out in April I've they've fixed it. Thanks for all your help and tips though, learned a fair bit about the whole kernel thing. – Jon Cox Feb 8 '11 at 19:24

In addition to gParted, PySDM might be able to help you with getting another hard drive mounted and its existence aknowledged:

PySDM is a Storage Device Manager that allows full customization of hard disk mountpoints without manually access to fstab. It also allows the creation of udev rules for dynamic configuration of storage devices. alt text

The left side of the PySDM screen should give you another opportunity to see if your other hard drive can be found in the partition table.

In Ubuntu, it can be installed by searching the Ubuntu Software Center for "pysdm". Once installed, it is available under the System --> Administration --> Storage Device Manager.

  • Thank you for the suggestion. Still no luck with this though. – Jon Cox Feb 8 '11 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.