ok, I'm brand new at this Ubuntu thing (used windows 7 all my life) and I need to know something? Can I burn Cd's on Ubuntu 12.04??? I've tried Basero, KFburn, and K3b and nothing. I've looked here and everywhere for my problem and found nothing. KfBurn simulates the burn perfectly, but when the player actually starts burning, it simply burns for a few minutes then stops... all three programs. I have a blu ray player and that's another problem for another time.. But for now:

I downloaded a 45 minute video from youtube and used "Sound Converter" to convert it to an audio file (wav. ogg. mp3 ect.). It plays fine on all the media players but I really don't care what format it's in, all I want is an audio CD that plays on a cd player.

I've loaded all the "dependency" packages from the repositories(though I don't really know what they are) it told me to.. I don't have alot of Cd's left so some guidance would be great at this point. Here's the bug report I got off of K3b (shortened to the error) if it helps.. thank you

Errno: 5 (Input/output error)

yes, I looked it up and was confused too.. My first problem was trying to get a fake RAID logical disk using 2 Sata SSD's and it worked but with funny fdisk results saying


MATSHITA BD-MLT UJ240AS 1.02 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, BD-ROM, BD-R, BD-RE, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW, BD-ROM, BD-R Sequential (SRM), BD-R Random (RRM), BD-RE] [SAO, TAO, RAW, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Random Recording, Sequential Recording, Sequential Recording + POW] [%7]


K3b Version: 2.0.2 KDE Version: 4.8.5 (4.8.5) QT Version: 4.8.1 Kernel: 3.2.0-36-generic

Used versions

cdrecord: 1.1.11


/usr/bin/wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits. scsidev: '/dev/sr0' devname: '/dev/sr0' scsibus: -2 target: -2 lun: -2 Linux sg driver version: 3.5.27 Wodim version: 1.1.11 SCSI buffer size: 64512 Beginning DMA speed test. Set CDR_NODMATEST environment variable if device communication breaks or freezes immediately after that.

Writing pregap for track 1 at -150 Starting new track at sector: 0 Track 01: 0 of 457 MB written. Track 01: 1 of 457 MB written (fifo 100%) [buf 99%] 8.0x. Errno: 5 (Input/output error), write_g1 scsi sendcmd: no error CDB: 2A 00 00 00 03 60 00 00 1B 00 status: 0x2 (CHECK CONDITION) Sense Bytes: F1 00 04 00 00 01 31 0A 00 32 7F 6E 09 90 00 00 Sense Key: 0x4 Hardware Error, deferred error, Segment 0 Sense Code: 0x09 Qual 0x90 (track following error) [No matching qualifier] Fru 0x0 Sense flags: Blk 305 (valid) cmd finished after 0.038s timeout 200s /usr/bin/wodim: A write error occured. /usr/bin/wodim: Please properly read the error message above. write track data: error after 2032128 bytes Writing time: 30.244s Average write speed 404.5x. Fixating... Fixating time: 0.000s /usr/bin/wodim: fifo had 223 puts and 33 gets. /usr/bin/wodim: fifo was 0 times empty and 32 times full, min fill was 99%.

cdrecord command:

/usr/bin/wodim -v gracetime=2 dev=/dev/sr0 speed=24 -sao driveropts=burnfree textfile=/tmp/qt_temp.eD9293 -useinfo -audio /tmp/kde-lucky1/k3b_audio_0_01.inf

  • Have you installed ubuntu-restricted-extras? And what type of CD are you trying to burn?
    – Seth
    Feb 5, 2013 at 0:47

2 Answers 2


That is a lot of questions all mixed into one, I would separate them out, it is difficult to know where to start.

As far as an audio CD, you need to save the audio file as a .wav , then burn it to disk.

In my experience, all the programs you mentioned will work. I find K3b is most reliable and has the most options. YMMV and I am sure you will get other opinions from other people.

  • sorry bout that. ok, here's the scoop.. First thing that happens, I put in a blank Cd, the immediate responce from the program (k3b) window is an Error: "Could not open document". I press ok but the file display on the left corner of the program acknowledges the empty disk's existence. I press the button for creating an audio cd and add the .wav file to the jobs list and run it (burn). It runs for 34 seconds before showing the error (thus eating another CD-r disk). I tried making sense of the bug report.. maybe it can help, I'll try posting it?? I appreciate your responding to this! :)
    – The Dude
    Feb 5, 2013 at 1:06

(i'm the developer of libburn, a competitor to cdrecord)

There is something wrong with the drive or the (SATA ?) controller resp. its driver software.

The drive returns an error diagnostic code that is not covered by the relevant SCSI specs (SPC in this case).

Sense Bytes: F1 00 04 00 00 01 31 0A 00 32 7F 6E 09 90 00 00 Sense Key: 0x4 Hardware Error, deferred error, Segment 0 Sense Code: 0x09 Qual 0x90 (track following error) [No matching qualifier]

The first byte should be 70 to 73, but never F1. Thus the interpretation of this diagnostic code by wodim (the cdrecord clone that issued these messages) might be misleading. The alternative form of sense data would yield a registered error code: 0 04 00 = No error. Logical unit not ready. Cause not reportable. But i do not believe that Sense Data Format F1 should be interpreted like this, which would be appropriate with format 72 or 73.

I have a blu ray player and that's another problem for another time..

Maybe not. I have a Sony BD-5300S Blu-ray burner which reliably goes mad when i just insert a CD. Afterwards, CD burned or not, it deformats BD-RE media (which is not an official feature of BD-RE) and spoils BD-R. To heal it, i have to switch off and on the electrical power of its USB box.

I see a similar error with Nero on a MATSHITA UJ240AS drive in http://club.myce.com/f61/panasonic-matshita-bd-mlt-uj240as-doesnt-work-not-perform-start-disc-once-323543/

Sense Area: 0x70 00 04 00 00 00 00 0A 00 00 7F 60 09 90

Here, the format code is covered by the specs. But the error code is 4 09 90, as with your wodim run. A non-official error.

So i would expect that this burner is not working properly and should be replaced. (Best with a different brand or model.)

Have a nice day :)


  • Now that's what I call customer support ;-) Great!
    – FuzzyQ
    Feb 5, 2013 at 9:39
  • Well, actually The asking Dude is not my customer, but an indirect user of the competition's ailing clone. (Do not use wodim for DVD or BD. Use growisofs or my stuff.) So this is general user support for GNU/Linux. :)) My answer is not very satisfying, of course. First because it offers no fix on software level. Second because it is undistinguishable from the statement "my software is not to blame" which was tradition in the world of free programs for CD burning. The second point is weakened by the fact that i have few reason to defend any errors in wodim or cdrecord. Feb 5, 2013 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.