9

Ok so I think this is because I am missing a package. My unity notifications (ex. when unity tells me it is connected to a network) look ugly. They used to be translucent chameleon rectangles. Now they are white and totally different. See the picture below.

enter image description here

  • Think back a bit and recollect if you've installed a new theme or accidentally deleted something you shouldn't have. Have you rebooted? If you do provide additional information, please do so by editing your question. – user25656 Feb 5 '13 at 1:02
  • That is what I have been trying to remember. Trouble is one of my friend got on my computer and screwed some stuff up. He uninstantiated system settings (gnome-control-center) which then caused me to lose indicator-power indicator-datetime gnome-control-center-signon and gnome-control-center-unity. I reinstalled them and every thing is back to normal but for this – chad Feb 5 '13 at 1:08
  • Have you rebooted? – user25656 Feb 5 '13 at 1:25
  • yes I have rebooted – chad Feb 6 '13 at 1:11
6

I figured it out. I had xfce4-notifyd installed so a quick sudo apt-get purge xfce4-notifyd solved the problem.

  • I had to logout and log back in for this to take effect. – jmiserez Sep 30 '14 at 9:31
0

Define and add name extension suffix .disable to unwanted freedesktop daemons:

$ grep -r org.freedesktop.Notifications /usr/share/dbus-1/services/
/usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service:Name=org.freedesktop.Notifications
/usr/share/dbus-1/services/org.freedesktop.Notifications.service:Name=org.freedesktop.Notifications
sudo mv /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service /usr/share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service.disable
pkill xfce4-notifyd

Sequently restart all notification using software.

Works just fine with mate issues also:

Replace xfce line to mate:

/usr/share/dbus-1/services/org.freedesktop.mate.Notifications.service.disable:Name=org.freedesktop.Notifications

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.