I'm struggling to get the embedded wireless card in this laptop to work. In 7.10 (gutsy) it worked fine. Now I'm trying to get 10.10 (maverick) working on it, and am using the Lubuntu flavour due to the low resources of this laptop.

The hardware: Appears to be an embedded pcmcia card. pccardctl ident gives:

Socket 0:
  product info: "TOSHIBA", "Wireless LAN Card", "Version 01.01", ""
  manfid: 0x0156, 0x0002
  function: 6 (network)

The default kernel recognises the card and loads the orinoco_cs driver.

orinoco_cs 0.0: Hardware identity 0005:0002:0001:0002
orinoco_cs 0.0: Station identity 001f:0001:0006:000e
orinoco_cs 0.0: Firmware determined as Lucent/Agere 6.14

Then for some reason, the driver isn't happy with this and gives:

orinoco_cs 0.0: Hardware identity 0005:0002:0001:0002
orinoco_cs 0.0: Station identity 001f:0002:0009:0030
orinoco_cs 0.0: Firmware determined as Lucent/Agere 9.48

All seems ok until I try to associate with my access point using Network Manager.

eth1: Lucent/Agere firmware doesn't support manual roaming

repeated about 10 times then NM gives up.

According to the linuxwireless.org wiki page on this driver, this is a known issue, and I quote:

Known issues

Roaming and WPA_supplicant

Lucent/Agere firmware doesn't support manual roaming

On the Agere cards, roaming is controlled by the firmware instead of userspace. You will get the above message if userspace attempts to associate with a specific AP rather than by SSID.

If you are using wpa_supplicant use ap_scan=2 mode.

NetworkManager uses wpa_supplicant, so the above also applies.

At this point my google-fu has failed me, and I can't find how to configure network manager to use the mystical "ap_scan=2" mode via wpa_supplicant.

I have tried the following suggested solutions (from launchpad or the forums)

  • deleting the agere* files from /lib/firmware
  • using wicd instead of network manager
  • combining both
  • blacklisting the orinoco_cs driver in an attempt to force use of the hostap_cs driver instead (in case it is a prism2 card).

Obviously none of them have worked for me.

Any hints on how to perform the suggested workaround above?

Edit: I have also confirmed working on 8.10 (intrepid) live CD.

closed as too localized by Bruno Pereira Mar 7 '12 at 20:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I have posted a new bug on launchpad with full output of wpa_supplicant and NM. It appears there is no configurable way of passing the ap_scan=2 parameter to wpa_supplicant via NM at the appropriate time. link – MoLE Feb 8 '11 at 22:35
  • Maybe you could try to install the same version of kernel of 8.10 or 7.10? Or the same version of NM? – desgua Jun 2 '11 at 14:14

Have you tried setting it like this:

iface wlan0 inet dhcp
        wpa-ap-scan   2

They're talking about a different driver, but it may be a way to slip that in through an interface config file. On the other hand, it kind of takes NetworkManager out of the picture and uses wpa_supplicant directly...so maybe not what you want.

Not the answer you're looking for? Browse other questions tagged or ask your own question.