The last update of PostgreSQL 9.1.7 seems to break my APT.

When I try to update, I get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 postgresql : Depends: postgresql-9.1 but it is not going to be installed
 postgresql-contrib-9.1 : Depends: postgresql-9.1 (= 9.1.7-0ubuntu12.04) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried to run apt-get -f install, same error.

Finally, I tried to remove everything using apt-get --purge remove postgresql, same error again.

Note: I installed PostgreSQL using the following PPA: https://launchpad.net/~pitti/+archive/postgresql


  • Anyone to help me?
    – 4e4c52
    Feb 5, 2013 at 19:18
  • Try aptitude. You probably have to install it first. When you run it, there should be a category of packages with unmet dependencies and you should be able to work them out there.
    – colboynik
    Feb 6, 2013 at 6:52

1 Answer 1


Check the FAQs. They have a lot of good answers to these kinds of questions.

How do I resolve unmet dependencies after adding a PPA?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.