0

I have tried several options from various forums. Proper calibration should not be this difficult.

I have run the calibration tool and most sites say to include a section of the output in a particular file in the /etc/x11/.... file. This file does not exist.

One site said the file was in the /usr/x11/.... directory and that an additional option for calibration should be added. This made no difference.

I included the section from the calibration tool in this file renaming the input device.

This also had no effect.

Does anyone know how to successfully calibrate my touchscreen, and can Ubuntu guru's develop the calibration software so that the output of the calibration tool is automatically stored where it should be?

1

I have a cf19 mk2 using any linux distro. xinput_calibrator is the program to use. Install it run it do what it tells you to do. the file needs to be in the directory /etc/X11/xorg.conf.d/ you may need to create "mkdir" xorg.conf.d. then a file is created in there by you and the output of xinput_calibrator run inside a terminal needs to be cut and paste into it. Slackware 14 is working very well for me at the moment, but if you are new to linux use the latest Ubuntu. Screen rotation needs xrandr -o "left,Right,Normal" to work but you need to research the extra options to those commands to include the t/screen settings. Good luck when it works it works VERY well, Cheers.

0

You need xserver-xorg-input-libinput (not sure), xserver-xorg-input-evdev, and xinput-calibrator.

sudo apt install xserver-xorg-input-libinput xserver-xorg-input-evdev xinput-calibrator

Once installed you have to run xinput_calibrator:

sudo xinput_calibrator

Now it shows a snippet like:

Section "InputClass"
    Identifier  "calibration"
    MatchProduct    "Fujitsu Component USB Touch Panel"
    Option  "Calibration"   "951 15763 526 15016"
    Option  "SwapAxes"  "0"
EndSection

(It have to be:

Option  "Calibration"   "..."

not with max_x etc...). You have to put the snippet in a file that you will have to edit, maybe:

sudo gedit /etc/X11/xorg.conf.d/99-calibration.conf 

So add a line in the snippet:

Driver  "evdev" 

between Matchproduct and the calibration. It took me hours to figure out that the snippet generated by xinput_calibrator did use old fashioned callibration and did not specify Driver, which became libinput by default.

restart x, and it should be done.

Edit: you can add some fun options:

Option  "SwapAxes" "0"
Option  "EmulateThirdButton" "1"
Option  "EmulateThirdButtonTimeout" "650"
Option  "EmulateThirdButtonMoveThreshold" "50"

enjoy ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.