18

I have mouse keys enabled on two computers running Ubuntu 12.04. On one of them, the cursor speed is reasonable. On the other one, even when using the same keyboard, the cursor moves unbearably slowly. Setting the key repeat speed to max does not help. Setting the mouse speed to max doesn't help. Setting the touchpad speed to max does not help.

Where's the setting for the cursor speed with mouse keys?

3

3 Answers 3

11

Try adjusting xkbset settings as i.e.:

xkbset ma 60 10 10 5 2

You can find xkbset on the universe repository.

Source: http://ubuntuforums.org/showthread.php?t=1977588

5
  • Can this be made permanent? It is a pain to type it every time.
    – krassowski
    Commented Apr 15, 2021 at 10:48
  • @krassowski Maybe this can help.
    – Baha
    Commented Jan 19, 2022 at 13:39
  • The method in my previous comment didn't help, so I added the command to .bashrc file in my home, however every time I turn on the numlock to use the numpad's numbers the pointer becomes slow again so I added an alias "fastkeys" to .bashrc and I'm using it every time it's slow. (I also use Guake terminal so access to the terminal to write the command is quick.)
    – Baha
    Commented Jan 20, 2022 at 14:02
  • In case "xkbset ma 20 10 10 10 10" doesn't work for you and gives you the error message "XKB not supported for display :0". I figured out an instruction that worked: askubuntu.com/questions/68807/how-can-i-configure-mousekeys/…
    – aysljc
    Commented Mar 31, 2023 at 4:55
  • This worked for me on Ubuntu 23.10 with X, nine years later.
    – Flimm
    Commented Nov 24, 2023 at 19:14
4

There is also this answer by Song Jong Márcio, which I just paste for completeness. Please upvote the original if you found it helpful.

The properties they change via terminal can also be edited in dconf-editor; you'll find the my searching for mousekeys, as pointed out in this answer.

Song Jong Márcio's answer:

Use gsettings to change the speed parameters keys.

  • To find these keys I used:

    gsettings list-recursively | grep keyboard | grep mouse
    

    I found:

    org.gnome.desktop.a11y.keyboard mousekeys-max-speed 10
    org.gnome.desktop.a11y.keyboard mousekeys-init-delay 300
    org.gnome.desktop.a11y.keyboard mousekeys-accel-time 300
    org.gnome.desktop.a11y.keyboard mousekeys-enable true
    
  • To know what each key does I use:

    gsettings describe org.gnome.desktop.a11y.keyboard mousekeys-max-speed;
    gsettings describe org.gnome.desktop.a11y.keyboard mousekeys-init-delay;
    gsettings describe org.gnome.desktop.a11y.keyboard mousekeys-accel-time;
    gsettings describe org.gnome.desktop.a11y.keyboard mousekeys-enable;
    
  • I performed the following procedure to change these keys:

    gsettings set org.gnome.desktop.a11y.keyboard mousekeys-max-speed 2000;
    gsettings set org.gnome.desktop.a11y.keyboard mousekeys-init-delay 20;
    gsettings set org.gnome.desktop.a11y.keyboard mousekeys-accel-time 2000;
    gsettings set org.gnome.desktop.a11y.keyboard mousekeys-enable true;
    

These key values ​​are personal, you must enter the values ​​that are suitable for you.

The image below shows how to control your cursor: enter image description here

Source: https://www.repairwin.com/wp-content/uploads/2019/03/image-8.png

1
  • 2
    Clearly this is the relevant answer for Ubuntu, and for Gnome desktops in general. Anything suggesting the use of xmodmap is way obsolete.
    – q.undertow
    Commented May 5, 2023 at 19:56
0

Okay, first install xkbset by using the following command;

sudo apt install xkbset

after installation done, set the value of mouse key speed, something like below; there are 5 parameter mentioned the 4th one (20) is responsible for pointer acceleration, set it according to your need;

xkbset ma 10 10 10 20 10

To make the setting persistent use xmodmap, you will need to create a file that specifies the desired key mappings, and then use the xmodmap command to apply the mappings.

Here is an example of how you might use xmodmap to disable the numlock key:

Create a file named .Xmodmap in your home directory, and add the following line to it:

clear mod2

This line tells xmodmap to clear the keycodes that are assigned to the mod2 modifier, which is used by the numlock key.

Run the xmodmap command to apply the changes:

xmodmap ~/.Xmodmap

This will disable the numlock key, causing it to have no effect when you press it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .