I recently upgraded from Tata Photon+ to Tata Docomo Photon 3G, however Ubuntu is not recognizing the device itself. I tried manually adding the device in Mobile Broadband section, using different APNs and Service provider names as suggested in few earlier questions. The device is ZTE MF 190 (hsupa). What do i do?

  • 3
    Are you sure that ubuntu doesn't recognize the device at all? Post the output of dmesg | tail after inserting the device. – nikhil Feb 8 '13 at 10:42
  • 2
    @TataDOCOMO Customer care is not at all helpful with respect to postpaid connections. It took me 2 days and multiple calls just to know the process of getting a connection activated. – asheeshr Feb 16 '13 at 8:18
  • 2
    @TataDOCOMO if you provide support for Ubuntu, why not leave instructions to help any of your users that find this post, otherwise just dropping a phone number, is painting a very poor image of your company. – Mateo Feb 16 '13 at 18:59
  • 2
    Have you tried using sakis3g? – ignite Feb 17 '13 at 8:33
  • 1
    Is there any update to this? Tata Photon 3G is not working on my ubuntu device. The interesting part is Reliance 3G(same model dongle) works brilliantly without any problems. – Tojo Chacko Jun 8 '13 at 10:08

Use sakis3g script

Sakis3G is a tweaked shell script which is supposed to work out-of-the-box for establishing a 3G connection with any combination of modem or operator.

It automatically setups your USB or Bluetooth™ modem, and may even detect operator settings.

It may work for you.

For details on sakis3g installation please refer to official Github page of sakis3g

For details on how to use sakis3g refer the official page

see this post for additional reference.


First you have to make sure the device is recognized as a modem and the proper ttyUSB or ttyACM are created.

Check dmesg output after the device is plugged in. Most 3G modems start their life as a cdrom device, and it is the job of usbmodeswitch to send the right command to bring the modem up.


I had the same problem,but then i checked. You just need to plug-in your dongle and select the Docomo network in networks section. It will works fine. If it doesn't then try installing mobile broadband drivers. Ubuntu should detect them automatically. If not,try downloading from internet

Not the answer you're looking for? Browse other questions tagged or ask your own question.