3

I have Logitech bluetooth adapter connected to my hi-fi system. When I connect to the adapter via Ubuntu's default installed bluetooth, and play some music, I get a really low quality sound. It's not the problem with adapter because when I connect to it from Windows on same PC sound quality is really good. I'm guessing that Ubuntu is using some low audio codec or driver is not adequate for playing sound over bluetooth.

Is there a solution for this kind of a problem? Is there a way to override default bluetooth driver and use something more adequate?

6

From the Sound Settings choose the Output tab to select your Bluetooth device. There we can change the audio profile to "High Fidelity Playback (A2DP)" in the "Mode" dropbox:

enter image description here

  • It's already selected. I have only two options in that combo box, one is "Off" and if i select that sound adapter will disappear from the list. So for playing any sound through bluetooth High Fidelity Playback (A2DP)" mode must be selected, in my case. – Milan Feb 2 '13 at 21:50
  • After pairing you may view settings and profile used by pulseaudio with this command: pacmd list-sinks. What exactly do you mean when you say "poor" quality? – Takkat Feb 3 '13 at 8:03
  • At least on 14.04, it seems to switch back to HSP/HFP even when set to A2DP. In my situation, it might be that the bluetooth speaker periodically disconnects and reconnects under the lower quality mode. – Ehtesh Choudhury Jan 26 '16 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.