6

How do I make byobu start with unicode support by default? If I have done byobu-enable how I can set this -u option?

6

Since you're asking about -u and not -U, I assume you're asking about Byobu's tmux backend...

In this case, you can add any additional tmux configuration options to a local tmux configuration at ~/.byobu/.tmux.conf. In there, you should add the following:

set-window-option -g utf8 on
set-option -g status-utf8 on

Full disclosure: I'm the author and maintainer of Byobu.

1
  • A recent answer says this didn't work. Any changes in the past two years? – muru Jul 16 '15 at 0:44
0

This might depend on how you start byobu. If you start it from the launcher like I do then you can follow the instructions in this answer to add the "-u" parameter to it: Specify parameters for launcher program .

Note: Dustin's answer, unfortunately, did not work for me for whatever reason. If I started a non-byobu terminal it had utf8 setup correctly and if I used tmux the characters showed up, but not with byobu's terminal.

Edit: To those who edited my answer to change the lowercase 'u' to a capital 'U' that is incorrect. A capital 'U' is not a valid parameter to input when starting byobu. Here's the text in my launcher icon: "env TERM=xterm-256color byobu -u". If you run byobu -u from a new terminal (not from byobu) it works, but if you run byobu -U it spits out a clear message that capital 'U' is not a valid parameter:

byobu -U

usage: tmux [-2lquvV] [-c shell-command] [-f file] [-L socket-name] [-S socket-path] [command [flags]]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy