All of a sudden there's this message of 'couldn't load plug-in' on chrome. Firefox is fine though, I tried updating flashplayer but it didn't work. Thoughts?

  • Very, very similar thread here: Google Chrome - couldn't load plugin - shockwave flash and a link to code.google.com/p/chromium/issues/detail?id=173790. It's still flagged as "unconfirmed" despite several me-toos.
    – user25656
    Feb 2, 2013 at 3:09
  • 5
    It's now "untriaged" but this comment explains the problem: "Unfortunately, was pushed out via the component updater, and using plugins from the component updater doesn't work on Linux (and breaks stuff, due to the way plugins are loaded). :( So deleting ~/.config/google-chrome/PepperFlash should fix things (unfortunately falling back to .137) ... and since we've stopped pushing .138, it won't reappear."
    – user25656
    Feb 2, 2013 at 6:20
  • 2
    @mlvljr - agree its annoying - yes its a bug which will be shortly fixed (see the triage comment link above) - hence, its both off-topic and too-localised. The 5K views would be expected. However I agree - I'll reopen for the moment - but in a few days when the bug is resolved, I'll close this again as too-localised since the question will be just for a specific moment in time.
    – fossfreedom
    Feb 3, 2013 at 21:24
  • 2
    This is now supposedly fixed - can someone confirm? googlechromereleases.blogspot.co.uk/2013/02/…
    – fossfreedom
    Feb 5, 2013 at 12:18
  • 1
    The bug has been fixed. I just did an update which included Google-Chrome. But, we have to go to /home/user/.config/google-chrome and rename (or delete) the PepperFlash folder. Then open Chrome browser, which will now load the plugin from the /opt/google/chrome/PepperFlash folder. The current version is Then, if you had enabled the Adobe version, disable it in chrome://plugins
    – Sri
    Feb 6, 2013 at 5:52

9 Answers 9


I solved the issue by moving the following folder to a backup:

~/.config/google-chrome/PepperFlash moved to ~/.config/google-chrome/PepperFlash.bak

After that kill all processes of Chrome (also the background ones for offline gmail and so on).

It works now for me. Must have to do something with the new rule that you have to enable plugins per page/site before they run maybe?

  1. Open up Google Chrome
  2. Type chrome://plugins into the address bar
  3. Look for Adobe Flash Player
  4. Click on +Details in the upper right corner
  5. Disable one of the Adobe Flash Player entries, and make sure one is Enabled

If you have installed the package flashplugin-installer you'll see two plug-ins, you can choose whichever you want.

For some reason it was disabled and at the beggining of the list you can also see another libpepflashplayer which is also disabled.

  • 1
    I have this same issue and I have typed in the the about://plugins and everything is enabled and still get the error couldn't load plugin Feb 2, 2013 at 2:50
  • @rstreeter78 Is every flash plugin you have enabled? Feb 2, 2013 at 3:08
  • Yes I believe so here are links to the images imagebin.org/245133 imagebin.org/245134 Feb 2, 2013 at 3:27
  • @rstreeter78 Try with one plug in at a time they might be conflicting with each other. Feb 2, 2013 at 3:37
  • 1
    I tried that and was unsuccessful Feb 2, 2013 at 3:54

In chrome://plugins, I disabled libpepflashplayer. Now I can watch youtube and Dateline. :D

  • oh..Just an update. OK to watch Dateline.. but can't watch on ABC.com. It's just blank... no error message.
    – user127947
    Feb 3, 2013 at 4:38

I can't seem to add a comment to Uri Herrara's answer, or even up vote it. But he set me on the right track.

Ubuntu installed a new image and Chrome, and the libpepflashplayer.so Flash player is not working. I disabled it, and the

Name:   Shockwave Flash  
Version:    11.2 r202  
Location:   /opt/google/chrome/plugins/libflashplayer.so  

is working fine

  • If you want to learn more about how this site works, I suggest reading the FAQ and About pages. Good luck and have fun!
    – Seth
    Feb 2, 2013 at 5:14

Don't know why, but the pepperflash plugin used by chrome seems to be crashing recently. Removing the plugin completely will do the trick temporarily, but will be recreated automatically at some point in time, probably after a relaunch of the browser or something.

rm -fr ~/.config/google-chrome/PepperFlash

This is the command to remove the plugin. Launching chrome thereafter should allow you to play flash via it defaulting back to the default adobe plugin.

If you don't want to go around blowing away directories, you can rename it:

mv ~/.config/google-chrome/PepperFlash ~/.config/google-chrome/PepperFlash.bak

It works too.

Again, just a temporary work around, but it works in a pinch until they fix PepperFlash.


I was able to get flash playing again by just disabling libpepflashplayer in Chrome via chrome://plugins/, no terminal needed, didn't even restart Chrome. Strangely I did not have any issues with Firefox.

  • I was also thinking why would Firefox have an issue when the pepper flash is for Chrome only. Oddly enough it was the only step I did. Feb 3, 2013 at 19:51

Well got lucky. Did the following after closing both browsers. Go to a terminal and:

rm -r ~/.config/google-chrome/PepperFlash

Then open any of the 2 browsers and go to their respective plugins section.

For Firefox it is in the menu in Tools --> Addons --> Plugins and check to be sure that the Shockwave Plugin is Enabled. Then test any flash video.

For Chrome, type in the URL: chrome://plugins and check that the plugin is checked there as Always Enabled.

Right now am testing to make sure both are working fine.

UPDATE - Yeap, both are working correctly again. Maybe it was an update that left a confusion there with the PepperFlash file.


The new release, Version 24.0.1312.69 has fixed this.


It's simple go to chrome://plugins and disable /opt/google/chrome/PepperFlash/libpepflashplayer.so.

Everything works like charm.

Not the answer you're looking for? Browse other questions tagged or ask your own question.