In Germany we use , as decimal mark instead of .. Since I installed my Ubuntu in English, the Ubuntu default calculator (gcalctool) uses the . and I can't use the , on my German numpad.

I already set up German in System Settings...=>Language Support=>Regional Formats but it doesn't seem to set it for the calculator. I also saw this question but I want to avoid remapping my keys.

Can someone tell me if and how I can change this for the calculator or recommend a calculator that supports it?

  • @gertvdijk could have included that in my question ;-) Edited it now. Feb 1, 2013 at 16:46
  • 3
    Do you see the , in the Regional Formats menu? I have the configuration like do you say and its working for me, this is my config and this are my results
    – Lucio
    Feb 1, 2013 at 17:25
  • @Lucio yes it looks exactly that way. I even clicked Apply System-Wide Feb 1, 2013 at 17:34

1 Answer 1


Sometimes it's the easy things. Inspired by @Lucio who said that this should work I rebooted and it does now. Now I also saw that it says "Changes take effect next time you log in.". Read first, then ask. Should have done this in the first place, sorry for that!

So for everyone who wants to achieve the same:

  • Go to System Settings...=>Language Support
  • Make sure the language for your format locale is installed. You can install it using the Install/Remove Languages button
  • Go to the Regional Formats tab and choose your country
  • Click Apply System-Wide
  • Reboot! (Or log out and back in. Should also work)

The default calculator should now accept the decimal mark used in your locale.

  • 1
    Good you found it. I think logging out and logging back in will also suffice.
    – gertvdijk
    Feb 1, 2013 at 17:50
  • Would be nice if there'd be a straightfwd way to just change the decimal mark (without affecting other stuff like date format)... Jan 27 at 7:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .