1

I am totally new to ubuntu. I installed adt(eclipse) from developer.android.com .. It is working fine. But when I try to start an AVD it says : Error:13 - Permission Denied.

I tried to start eclipse with sudo ./eclipse but I am still getting the same error .

  • You might want to consider using Android Studio instead of the older Eclipse Android IDE. I've had a much easier time getting things like AVDs and the SDK manager working with Android Studio. Just a thought. – Ian Jul 25 '15 at 16:33
2

There are several solutions corresponding to your problems.

  1. The correct SDK and tools are not installed. For this you need to go to the location where you have downloaded Android-SDK and start the android.sh. Then download required platform/build tools along with required files for any API.
  2. SDK tool is not getting execution rights. To solve this problem, navigate to the SDK location directory and type the following in your terminal.(as root if necessary).
    chmod -R +x Android-SDK
    Replacing Android-SDK with the name of your SDK directory.

Note : Android is shutting down its project for eclipse support, so I suggest migrating to Android Studio as soon as possible. Check here for details.

1
sudo chown -R username:username Directory(whatever)
sudo chmod +x directory (whatever)
0

You should not start eclipse with sudo. Make sure that you follow instruction on Android Developer Tools.

Also, make notice:

Important: Support for the Android Developer Tools (ADT) in Eclipse is ending, per our announcement. You should migrate your app development projects to Android Studio as soon as possible. For more information on transitioning to Android Studio, see Migrating to Android Studio.

0

As part of solution:

1) Check that you can get adb version by typing adb version in console.

1.1) Check that you are using same adb in eclipse and in console if #1 is working. Type which adb in console and compare path to adb with path to adb in Eclipse.

2) Open AVD manager and check that android tools are installed.

3) Check path

4) Check that adb wasn't installed by other user, or check execution rights.

Solution that helped: install IA32 if you are using 64 bit architecture.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.