I am really messed up with one of my partitions. I am new to linux and created a 210GB huge partition as swap. I tried converting it to a regular ntfs partition, but my computer hanged up despite having 6GB of RAM (in system monitor I saw that at that time it was taking whole 6GB of RAM and 4GB of swap memory), i had to turn off my computer since it was heating up. Then I started computer again, tried to delete the swap partition but failed. I formatted it as ntfs and succeeded this time, then it is not mounting and giving me error

Error mounting: mount exited with exit code 21: fuse: mount failed: Device or resource busy

after failing to mount it, I tried deleting it, but failed again, when I try to delete get the following error

Error erasing: helper exited with exit code 1: In part_del_partition: device_file=/dev/sda, offset=115845627904

Can anybody help please?

  • Just curious, any particular reason for the 210GB Swap? – saji89 Feb 1 '13 at 12:03

I assume that you boot your machine with an Ubuntu live image or Partition Magic?

In these cases the machine will mount the swap partition during the startup process. In order to re-define or delete the partition, you will first have to switch off its usage. You can do this either with your partition tool or from the command line with

sudo swapoff /dev/name of the device

After that you can proceed as with any other partition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.