9

I use a good deal of the default Ubuntu shortcuts as shortcuts in Emacs (Alt-Space is the most important). I obviously have disabled these shortcuts in the keyboard shortcuts dialog, but for whatever reason, they sometimes "come back", generally after I've installed/uninstalled certain packages, or upgraded Ubuntu.

My question therefore is: how do I keep these shortcuts disabled? I don't want shortcuts like Alt-Space restored for any reason.

  • No one? :( I did a software update (no new installed packages) and again Alt-Space as well Ctrl-Alt-Arrows have reappeared. So annoying. – Christopher Monsanto Feb 4 '13 at 9:16
  • Agreed! Maybe you can add something to your login script. – Jay Bazuzi Feb 7 '13 at 18:32
  • That is one of the reasons that I use fluxbox as my window manager. There, the keyboard shortcuts can be edited in a text file and moved around different machines. – rvf0068 Feb 7 '13 at 23:07
1

There are several ubuntu bugs in launchpad about keyboard shortcuts settings being reset to default.

It seems that when you switch the 'Backend' setting to 'Flat-file Configuration Backend' in CompizConfig Settings Manager under 'Preferences', the keyboard shortcuts changes seem persistent. You'll have to do a unity --replace for the changes to take affect.

| improve this answer | |
  • Thanks for pointing out this 'Backend' option. Can you please edit your answer to tell us where the 'flat files' are stored? – Lambart Oct 2 '13 at 21:19
0

Try gconf-editor then search for the keybinding under Edit -> Find search also in key values
You should be able to find your keybinding here, then unset it or change it to something else

| improve this answer | |
  • this does not answer the question – Lambart Oct 2 '13 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.