I just recently installed Ubuntu on our desktop PC and my father uses an Forerunner 305 GPS wristwatch when he goes out for a jog.

On Windows he always used the the program Garmin Trainingscenter to import the data gathered during his run (things like the route he did, speed, distance etc.). I searched on internet and saw that Pytrainer was a program which offered the same features and also had support for the Forerunner 305.

So I installed it but when I press the "import" button, initially it looks like he is importing the data (the Forerunner gives a bleep and a progress bar is running). But when he is done, nothing shows up in the program.

Is there someone here who also has this GPS watch and got it to work under Ubuntu? If so, is there something I am doing wrong? I am using the latest version of Pytrainer (version 1.9.2-dev) and "gpsbabel" (a program needed to communicate with the watch) that came with Ubuntu 12.10.

Update 7 February

I was just experimenting and I tried an import via the garmin-forerunner-tools package instead of gpsbabel. Although results didn't show up in Pytrainer, it did create a .dump file in the ~/.pytrainer/tmp folder. I tried to manually import that file and that actually showed up in Pytrainer! :D

Alright, it's a very dirty workaround but we at least know that communication and exporting works. Now to just let Pytrainer import automatically when I press the button


Alright. Somehow I got it to work by myself.. I am not sure how I did it, but if you are, like me, having trouble getting your Forerunner 305 to work on Ubuntu, I'll describe what I did here.

  • If you haven't already, install Pytrainer trough the Ubuntu Software Center.
  • You'll also need to install an extra library in order to communicate with the Forerunner so execute this command in the terminal, or search for the package in the USC: sudo apt-get install garmin-forerunner-tools
  • Now open up Pytrainer and open in the menu Tools > GPS Device Plugins
  • Select the "Garmin via garmintools" option and press "Preferences"
  • Enable the plugin by selecting the "Enable" option under Status.
  • Now connect your Forerunner to the PC with the USB cable and go to File > Import from Garmin GPS Device (via garmintools)
  • Notice that your device gives a beep and a progress bar will show. It might seem like the program crashed (Pytrainer turns grey) but after a few seconds it should come back to live, and your activities should show up in Pytrainer!

If you run into problems, make sure that there is an recorded activity that is not older than 30 days! Pytrainer will not import activities that are older than that. You can change this default value in the preferences.

I also saw somewhere on a site that it might fail to import your tracks when there is one with a special character in it's name. So make sure you won't name any tracks with special characters.

Took me a while to figure all this out since there is not a whole lot of information about it on the internet. I hope this is of use for some more people running into problems!


Quite some time since I last did it, but I think I could just access the watch as a mass-storage device, copy the training data file off the device (very strange naming conventions, you'll have to dig for it) and I then uploaded it to my.garmin.com. Not sure whether that helps you...

  • Ah, sorry, just remembered: I got a 210... – Michael Wild Feb 1 '13 at 10:58
  • I can't mount the watch as a mass-storage device it seems.. :/ But I seem to be able to at least connect with it using gpsbabel.. (the device gives a small bleep) – Gladen Feb 1 '13 at 21:49

Try alternatives:

GTrainer http://kutxa.homeunix.org/gtrainer/#download

SportsTracker http://www.saring.de/sportstracker/webstart/sportstracker.jnlp

  • Thanks for the the links. I tried them but they don't quiet provide the same functionality as Pytrainer. My father wants Google Maps integration to view the route he ran. – Gladen Feb 8 '13 at 15:13

Sometimes Garmintools will not import. But it may still load two files into the ~/.pytrainer/tmp folder. Navigate to the current year and month. You will find two files for each run, named yyyymmddThhmmss.dump and .gmn, respectively (substitute year, month, date, hour, minutes, second).

Delete these files and try importing again. It worked for me.

I suspect it has something to do with the usb connection or when I connected the watch - before or after loading the program.


Direct acces from pyTrainer with this combination does not work:

  1. Ubuntu 19.04
  2. pytrainer 2.0.0rc1
  3. garmin-forerunner-tools 0.10repacked-11

But you can read data from Garmin Forrunner 305 directly with garmin-forerunner-tools 0.10repacked-11 using the commandlines:

  • garmin_save_runs
  • garmin_dump

Could not find anyone who got Ubuntu 19.04 work with pyTrainer ...

  • Unfortunately it's a rather old device nowadays. My father bought a new one a while ago so can't try it for you. You could try using an older version of PyTrainer if that's possible to see if that still works, but community support is probably getting worse as time passes as more people are replacing the device. – Gladen Jul 1 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.