I installed ubuntu 12.10 64 bit version in my system. I want to disable all the usb ports. Except usb keyboard and mouse. I tried to add a line blacklist usb_storage in the /etc/modprobe.d/blacklist.conf and run the command sudo modprobe usb_storage. Reboot the system. But still the usb port is detected. What is the problem?

Anyone can help me to find the solution?


For every device there will be modules in our kernel which will be installed with our OS to make work them you have to just enable their modles so in ubuntu usb enabling modules will be /usr//lib/modules/3.2.0-36-generic-pae/kernel/drivers/usb/storage/usb-storage.ko as of mine is [UBUNTU 12.04] and kernel number may differ in yours go to that destination as shown above and type in terminal as sudo modprobe usb-storage.ko as superuser it may ask for password and it will enable them and to check if they are enabled or not type in terminal as lsmod |grep usb* And if it shows any usb storage then u have enabled it thats all for more info MODROBE INFO LSMOD INFO

| improve this answer | |
  • Thanks for info, but there is no file like /usr/lib/modules/3.2.0-36-generic-pae/kernel/drivers/usb/storage/usb-storage.ko in ubuntu 12.10. Can you give me a correct path to disable the usb port in ubuntu 12.10. Anyother options is there to disable the usb ports. – Naveen Govindarajan Jan 31 '13 at 14:26
  • @NaveenGovindarajan Welcome to Ask Ubuntu! Please use the contact us link at the bottom of this page to ask for your unregistered account and your new registered account to be merged. Thanks. – fossfreedom Feb 2 '13 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.