Lubuntu uses PCmanFM as it's default file manager. I want to access my samba share with PCmanFM to upload and download files. I've already installed the "samba" and "cifs-utils" packages and thier dependancies. Installing them seems to allow me to see the windows network which I can open and see my workgroup, but I cannot open the workgroup. It looks like nothing happens when I click on it, but after a minute or two I start to get "Failed to retrieve share list from server" and "The specified location is not mounted" messages. I should have to authenticate a username and password before I can access the samba share, but no dialog comes up asking for any info.

How can I get PCmanFM to access my shared files?


This should work:


in the PCmanFM address bar.


Courtesy: https://help.ubuntu.com/community/Lubuntu/PCManFM#Browse_Windows_PCs_with_Samba


If you want to connect as a particular user, use


Under Lubuntu 14.10, this brought up a password dialog and then connected with the expected ownership and privileges.

Courtesy: Comment by Randall Cook

FYI, PCmanFM mounts samba shared devices in /run/user/userid/gvfs (id -u can help to find user id) so after mounting Samba shares using PCmanFM, we can also access files/directories using console

  • 1
    Thanks for the tip, Saji, I tried in Raspbian with LXDE and works just fine.
    – rodrunner
    Sep 23 '15 at 20:05

I had the same issue on Lubuntu 17.10 and smbclient -L WINDOWS-PC always returns this error:

 protocol negotiation failed: NT_STATUS_INVALID_NETWORK_RESPONSE

By adding the following line in global settings of /etc/samba/smb.conf, it solves my issue for smbclient and pcmanfm:

    client max protocol = smb3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.