I just ssh'd into my old netbook (running as a CUPS server) running ubuntu server 12.04 and did a dist-upgrade (haven't done one in a while). Upon rebooting the machine, I can now no longer access it remotely at all! SSH doesn't work, HTTP doesn't work (CUPS web interface), I can't even make it respond to ping.

However, the machine still appears to have full access to the network and the internet- it can, for example, wget my IIS server on another machine in my network. I tested this by physically logging in at the machine.

The only thing I could think of is some kind of firewall issue (although I never set it up), so I did iptables --list but there are no firewall rules at all and everything is set to ACCEPT.

I'm a bit stumped as to why my server is suddenly pretending to be invisible!

EDIT: I think I've managed to get a bit closer to this- turns out, the machine isn't even responding to ARP broadcasts. If I try and ping it and look at wireshark on the pinging machine, I see lots of "Who has (the netbook)? Tell" with no reply.

Still at a loss as to why that would happen though...

EDIT EDIT: I ran tcpdump -nSvv arp on the netbook and tried to ping it from didn't see anything, pings timed out. I then pinged from the netbook, which succeeded, and I saw the arp messages in tcpdump. Pinging the netbook from again now works, because they already exchanged arp info- but attempting to access it from another machine (my phone) still fails.

When pinging from the netbook, it broadcasts an arp request to everyone, which responds to. then sends an arp request, to the netbook's MAC directly, which succeeds. What this therefore looks like is that the netbook is not responding to anything sent to a broadcast MAC. It only responds to arp requests directed at it specifically.

EDIT EDIT EDIT: Seems to be exactly this probelm, same wireless driver and everything: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/414724

  • Since this is not a headless machine but a netbook, what does the terminal on the physical hardware say? Can you log in on the terminal on the machine itself? – gertvdijk Jan 31 '13 at 0:00
  • Yup, that's how I know that it still has full outbound network/internet connectivity. I'll update the question to clarify this. – KJ Tsanaktsidis Jan 31 '13 at 0:07
  • Ah okay, then what do logs say? Are the services listening on the ports you expect them to listen? (e.g. sudo netstat -ntlp) Does it still have the same network address you expect it to listen on? (ip addr ls). Etc. etc. We'll need much more specific information to have your question answerable. – gertvdijk Jan 31 '13 at 0:11
  • It does indeed have the right network address, and everything is listening on the right ports because from the netbook I can do, for example, "ssh" and it successfully SSH's to itself. I'll take a look at syslog – KJ Tsanaktsidis Jan 31 '13 at 0:23
  • And there's nothing particularly interesting in syslog. I know my question is a bit vague, but I don't really know what information might be relevant to this kind of problem! Since it happened after a dist-upgrade, my feeling is that some default has changed, but other than iptables I don't really know what parts of the system would have anything to do with this – KJ Tsanaktsidis Jan 31 '13 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.